Turn key and I got NOTHING... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Turn key and I got NOTHING...

~Artec JK 1 TON SWAP~NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WDRear Disc Brake Conversion Kit- TJ,YJ,XJ

Reply
Unread 08-13-2011, 08:16 PM   #1
98GCLim40
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: Augusta, GA
Posts: 8
Turn key and I got NOTHING...

I purchased my most recent Jeep about 6 months ago and I don't think I have gone a week without something going bad.

My new problem has me confused and frustrated more then anything...

Today I got in it at the grocery store and turned the key and got nothing. No lights on the dash, no start. Flustered and back end full of groceries I popped the hood to make sure the connections on the battery were good. CHECK... Got back in and it started right up...

Got home, unloaded groceries and realized I forgot beer (no beer runs on Sunday so this was very important). Got into the Jeep and NOTHING...

Since I was home, I decided to check things over more closely, kept the key turned to on and started pulling fuses in the passenger compartment to see if anything happened - got to fuse #7 (BCM/amp/instru panel) after pulling it the fuel pump kicked on. plugged it back in and dash comes alive. started right up...

Got to liquor store. Same thing. Same fix. Some solution...

I know this isn't a real solution...

I'm thinking BCM but if I got a "new" one from the junk yard will I need to have it flashed at the dealership or anything?

Could it be anything else?

98GCLim40 is offline   Reply With Quote
Unread 08-13-2011, 09:55 PM   #2
JeepFreak1982
Senior Member
1998 ZJ 
 
Join Date: May 2011
Location: Middle Island, New York
Posts: 808
I have had some funny issues with my 98 5.9 also. I never had one like that but every long once in a whole the gauges dont work, radio turns on but no sound, ac blower blows but not cold, no power windows, and the red LED on the dash for the OEM alarm would stay lit the while time i was drifing. This all leads back to that same fuse. I pull it and all is back to normal. I finally pulled it, cleaned up the terminals real well, put a new fuse in and so far so good.
JeepFreak1982 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.