Transmission troubles have searched and still have ??? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 07-30-2009, 05:41 PM Thread Starter
Donerstude
Registered User
1989 XJ Cherokee 
 
Join Date: Oct 2008
Location: Irvine,Ca
Posts: 162
Transmission troubles have searched and still have ???

First off I have done a ton of searching and am still a bit confused here is the situation:
I have a new to me 95 ZJ 4.0 l automatic transmission 42re and 320,000 miles. when driving from a dead stop (stop light or sign) I move the lever to 1st gear all is fine 2nd gear is fine to but if I start from a dead stop in Drive/overdrive it does not start in first gear it seems to be in 2nd or maybe 3rd the Jeep has no power what so ever until i get up to about 15 to 20 mph. I know 1st works fine if the lever is in 1st. the overdrive button/switch light is always on I tried the trick of turning the key on and off but the overdrive switch light never flashed.
In my searching I have found that this may be the accumulator spring? or possibly the bands need adjustment? or maybe I have a bad solenoid? or possibly a bad TCM?
anyone have any ideas? I do not want to just start throwing parts at this so any way to narrow this down will be helpfull!

lastly I know this car has obd1 if i get the codes pulled will it pull the codes from the TCM are the code even stored in the TCM? and where do I plug the code reader in.

thanks for all the help, I would really like to fix this as inexpensively as possible and know I can do the work if I just knew which work to do.


Black Jeep Society #276
89 XJ Cherokee 4x4
95 ZJ Grand Cherokee 2x4
Donerstude is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-30-2009, 06:48 PM
anticrombie
Registered User
 
anticrombie's Avatar
1996 ZJ 
 
Join Date: Jul 2004
Location: Raleigh NC
Posts: 3,027
The reason you're feeling as if it's starting in second is because it is starting in second (or is it third?). It's called limp mode. When your tranny has something act up in it, it puts it in this mode to save itself. It's ok to drive it like this, I'd just limit it to getting it home.

Mine did this and it turned out to be the governors and pressure sensors in the valve body. thankfully I had 3 extra 42re's laying around and I swapped it out from one of those.
anticrombie is offline  
post #3 of 6 Old 07-31-2009, 10:21 AM Thread Starter
Donerstude
Registered User
1989 XJ Cherokee 
 
Join Date: Oct 2008
Location: Irvine,Ca
Posts: 162
Thanks for the info I was hoping I might be able to fix it instead of replacing it, anyone else have any suggestions?

Black Jeep Society #276
89 XJ Cherokee 4x4
95 ZJ Grand Cherokee 2x4
Donerstude is offline  
post #4 of 6 Old 08-01-2009, 10:23 AM
Devonreed
Registered User
1987 XJ Cherokee 
 
Join Date: Dec 2008
Location: sneads ferry
Posts: 17
my 94 zj 4.0 did the same thing on its last voyage it acted slugish but got up to speed slowly.about 10 miles later after it shifting fine. i stoped at a stop sign and went to take off when it lost all power to the rear wheels and just reved.it finnaly caught but never made it to thired gear.it just reved i pulled over and tried to reverse but it did the same thing just reved.i let it cool and tried it again it started off fine until it had to shirt,it just reved.it did move tho so im not convenced its the trans.it also did reverse once i got it home it even drove a little more not very far thow. can anyone help
Devonreed is offline  
post #5 of 6 Old 08-01-2009, 05:59 PM
StellaTheZJ
Registered User
1996 ZJ 
 
Join Date: Jan 2009
Location: BC
Posts: 629
Consider putting in a shift correction kit. They come with a pile of replacement parts, and when I did one on a 94 GC recently, we found the accumulator spring was broken... but there's a new one in the kit! Check out Transgo and Superior kits, as they're cheap they improve your tranny, and you'll be in there anyhow (sounds like).
StellaTheZJ is offline  
post #6 of 6 Old 08-03-2009, 02:01 PM Thread Starter
Donerstude
Registered User
1989 XJ Cherokee 
 
Join Date: Oct 2008
Location: Irvine,Ca
Posts: 162
Thanks ! I will look into these kits I hope it will fix my problem.

Black Jeep Society #276
89 XJ Cherokee 4x4
95 ZJ Grand Cherokee 2x4
Donerstude is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
5.9 transmission troubles kajeeper ZJ Grand Cherokee Forum 4 01-05-2010 07:03 PM
98 ZJ Transmission Troubles ChrisSD ZJ Grand Cherokee Forum 4 11-19-2008 11:01 PM
95 gc transmission troubles jslofts ZJ Grand Cherokee Forum 1 12-11-2007 08:31 PM
Transmission Troubles! UofOJeeper ZJ Grand Cherokee Forum 4 03-29-2007 02:02 PM
Transmission Overdrive Troubles heimeken ZJ Grand Cherokee Forum 5 01-07-2004 06:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome