Transmission slipping help - JeepForum.com
 1Likes
  • 1 Post By Timo_90xj
 
LinkBack Thread Tools
post #1 of 4 Old 01-13-2017, 09:45 PM Thread Starter
95JEEPGC
Registered User
1995 ZJ 
 
Join Date: Jul 2016
Posts: 2
Garage
Transmission slipping help

I recently purchased a project ZJ from someone I worked with for $250 and it was stuck in limp mode. I replaced the tranny fluid, installed a NOS trans control module from eBay and now it shifts almost perfect throughout all the gears and the OD is back. The one and only problem now I notice if I hit the gas fast or punch it from a stop, the transmission will slip momentarily or at least it feels like the transmission is slipping. It will only do this when the accelerator is applied fast from a stop, if I apply the accelerator in a normal fashion the gears shift smoothly both up and down. Any ideas on cost efficient fixes? Tighten bands? Transfer case problem? or is the transmission fried? The weather cold/hot has no difference in the symptoms. Its hard to always ***** foot the gas pedal and I wanted to get some opinions before I tear into this project to much. -Thanks

-1995 Jeep ZJ Laredo
-4.0L
-42re trans
-249 xbox
-138,000 miles

95JEEPGC is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-13-2017, 09:55 PM
TheGordeaux
Registered User
 
Join Date: Dec 2016
Posts: 1
How about torque converter?

Sent from my SAMSUNG-SM-G925A using Tapatalk
TheGordeaux is offline  
post #3 of 4 Old 01-14-2017, 08:31 AM
Timo_90xj
Web Wheeler
 
Timo_90xj's Avatar
1998 ZJ 
 
Join Date: Mar 2006
Location: Helsinki, Finland - on the European side of the Atlantic
Posts: 8,649
Are you sure it starts on 1st gear, not second or third? To me this sounds like a classic case of transmission solenoid & sensor issue, not mechanical.

Slipping under heavy throttle can be caused by misadjusted TV-cable. It it's too loose, transmission will not necessarily drop down to a lower gear, and it will not provide full line pressure under heavy throttle. Correct TV-cable adjustment is essential for the tranny to function properly, also preventing excessive clutch pack and brake band wear under heavy throttle.
SpeedShadow95Z_ likes this.

1998 Grand Cherokee 5.9 LX daily driver, 1.75" BB, 32" KM2s, HPD30 Eaton e-locker/D44a stock LSD, 4.56 gears, custom- fabbed tube bumpers and tube fenders,...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



1990 XJ Limited (4-door), 4.0 I6, AW4, NP242, ***rolled and totalled @ 165k miles***

***Under construction***
1990 XJ (4-door), 4.0 I6, AW4, NP242, PBR 42" tires, Unimog 404 portal axles, 110" WB, full cage + uniframe completely rebuilt, front 3-link + panhard / double triangulated 4-link rear,... ***SOLD***
Timo_90xj is offline  
 
post #4 of 4 Old 01-14-2017, 11:56 PM Thread Starter
95JEEPGC
Registered User
1995 ZJ 
 
Join Date: Jul 2016
Posts: 2
Garage
My ZJ was in limp mode when I bought it because of a bad transmission control module (TCM), it would always start off in 3rd gear and was very noticeable. After switching the TCM out, the full range of gears came back including OD, my TV cable seems to be OK and I have tested it on multiple settings to make sure, I even switched the governor pressure sensor and solenoid when I dropped the pan to change the filter and fluid. The torque converter might be a good idea. Would tightening the front band help with the hard acceleration stutter/slipping issue? Maybe clogged cooler lines effecting the clutch pressures?
95JEEPGC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome