Trans Shudder - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Trans Shudder

WJ Shackle Tabs: Tow-Hook Replacements2014 Spartan Locker Special - While Supplies Last! Dana 3FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 01-28-2013, 10:07 AM   #1
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,547
Trans Shudder

Ok, so I recently replaced the Governor pressure sensor and solenoids on my '96 5.2 Limited. Also tossed in a new filter and fluid.

It seems to have fixed my issue with not automatically shifting into 1st when coming to a stop. The Jeep still takes a bit of throttle to get moving, but I attribute that to either being a high mileage trans (223k), the fan clutch is failing, or a combination of both.

During my test drive after the repairs I noticed a couple things:

1- When accelerating between 25 MPH and 40 MPH if I get on the throttle 50% or more, I get a shudder/vibration throughout the vehicle. This was not an issue before the parts were replaced.

2- The trans won't downshift from 3rd or 2nd into first if I floor it. I would expect it to downshift into first if I'm crusing around 30 MPH, correct?

Any ideas on the shudder/vibration problem?

I assume my downshift issue could be related to the TV cable needing adjustment, or should I look elsewhere?

__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote Quick reply to this message
Unread 01-28-2013, 01:53 PM   #2
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,547
Ok, so here's a little more info after driving it today for lunch:

Trans fluid was about half a qt. low, I topped it off, but it did not help the issue.

Now that the roads are clear of snow, I can get a better feel for what the standstill accelerration. Now it feels like the replacement parts I put in did not fix the problem. Putting the shifter into 1st makes the trans feel more responsive.

The engine will not rev above 2K RPM when starting from a standstill, when cruising between 30 and 40 MPH, it will downshift into 2nd and the RPMs will go above 2K, but that's the only time.

I pulled the CEL codes (light NOT on) using the key trick and I got code 45 twice. Obviously my engine is not turbocharged, so I assume this is a trans code.

My searching online indicates that trans code 45 could be the trans temp sensor, which is built into one of the solenoids I replaced. I did not get an over temp warning on my VIC.

Any ideas?
__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.