Trans over Temp light come on and P0740 code - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Trans over Temp light come on and P0740 code

NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineYear End Clearance Sale! Save 20%

Reply
Unread 04-20-2008, 01:36 AM   #1
luigi120
Registered User
2001 WJ 
 
Join Date: Jan 2008
Location: venezuela
Posts: 7
Trans over Temp light come on and P0740 code

Hi there, its my first time posting.... i have a Wj 2" lift kit with 31" tires .... recently when i go in open highway for more than an hour drive the check engine light come on and then the trans over temp light come on too and the fan run faster than normal.... i wait 5 min to the trans over temps light goes off to drive again.... I took out the code and P0740 its the code that it gave .... any help i dont know what to do?


Last edited by luigi120; 04-20-2008 at 02:57 AM.. Reason: instant notification
luigi120 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2008, 01:47 AM   #2
WiLieR
Registered User
1999 WJ 
 
Join Date: Jul 2007
Location: Madison, MS
Posts: 295
Need more info. Year of jeep. Engine size.
__________________
99 WJ Laredo - Mine once again!
WiLieR is offline   Reply With Quote Quick reply to this message
Unread 04-20-2008, 02:06 AM   #3
luigi120
Registered User
2001 WJ 
 
Join Date: Jan 2008
Location: venezuela
Posts: 7
Wj 2001 , 4.7 L, 45RFE transmission
luigi120 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2008, 09:07 AM   #4
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
Torque Converter Clu No RPM Drop at Lockup

Relationship between engine and vehicle speeds indicated failure of torque convertor clutch lock-up system (TCC/PTU sol).

Got this from wjjeeps.com, is the fluid low?
JeepOrvis97 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2008, 01:32 PM   #5
luigi120
Registered User
2001 WJ 
 
Join Date: Jan 2008
Location: venezuela
Posts: 7
that is the P0740 description (Torque Converter Clu No RPM Drop at Lockup Relationship between engine and vehicle speeds indicated failure of torque convertor clutch lock-up system (TCC/PTU sol).) but what i have to do to repair it? what do i need to change to avoid the light come on?....

and the fluid its ok. I change the fluid and filter thinking it can solve the problem but it didint... and the light come on again.
luigi120 is offline   Reply With Quote Quick reply to this message
Unread 04-25-2008, 08:22 AM   #6
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
Ok, it looks like you need a scan tool for the following test... I would take it to a good transmission shop if I were you because Automatic transmissions are a pain to work with.







P0740-TORQUE CONVERTER CLUTCH CONTROL CIRCUIT

When Monitored and Set Condition:
P0740-TORQUE CONVERTER CLUTCH CONTROL CIRCUIT

When Monitored: During Electronically Modulated Converter Clutch (EMCC) Operation.

Set Condition: Transmission must be in EMCC, with input speed > than 1750 RPM. TCC-L/R Solenoid achieves the maximum duty cycle and can not pull engine speed within 60 RPM of input speed. Also when the transmission is in FEMCC and the engine slips TCC > than 100 RPM for 10 seconds.

POSSIBLE CAUSES
RELATED DTC P0750 PRESENT
INTERMITTENT WIRING AND/or CONNECTORS
INCORRECT FLUID LEVEL
INTERNAL TRANSMISSION PROBLEM - TCC OUT OF RANGE
L/R SOLENOID INOPERATIVE
JeepOrvis97 is offline   Reply With Quote Quick reply to this message
Unread 08-17-2009, 08:35 PM   #7
slegerjr
Registered User
1989 XJ Cherokee 
 
Join Date: Jan 2009
Location: FtW
Posts: 8
I have just now started having the same kind of problem with my 2002 cherokee limited. I changed the filter and fluid today. When I got on the highway to take my son home, The trans overe temp light and the o/d off light came on. When I pulled over to check the fluid level, I noticed a little smoke coming ont of trans dip stick. Now I know this can't be good. Has anyone else ran into this problem before. I really dont have the money for this type of problem right now. I dont know what to do. H E L P Please.

I found something on the internet about a recall from 99 to 04 models that mentioned there was not enough flow of fluids through the transmission. Is there anyway to have jeep dealer fix this recall or are there guidelines to recalls. Is there a expired time period that I would have to worry about?

Last edited by slegerjr; 08-17-2009 at 08:39 PM.. Reason: didnt say everything I wanted to say
slegerjr is offline   Reply With Quote Quick reply to this message
Unread 10-25-2010, 11:54 AM   #8
Kevin5097
Registered User
2002 WJ 
 
Join Date: Oct 2010
Location: Westmoreland
Posts: 2
i too have the same problem, (posted on another page). I have a 03,GC 6 Cyl. Wonder how many more of us are victims???
Kevin5097 is offline   Reply With Quote Quick reply to this message
Unread 11-26-2010, 09:17 AM   #9
gordon
Registered User
2003 WJ 
 
Join Date: Oct 2009
Location: Atlanta
Posts: 104
I too have the same problem, after towing my boat on the HWY for an hour. (WJ GC 2003 4.7 v8 45RFE). P0740 comes on and this time Trans Temp alarm light comes on too. I pulled over and after 5 mins of idle the trans cooled down and I drove home more gently with no problems. I also checked the tranny fluid and it looked to be at the right level.

After reading on this forum I am going with the theory that I may have fluid flow issues due to possibly dodgy cooler lines. Fluid flow/low fluid pressure being limited could cause a) Tourque Converter Unable to lock up b) Transmission to overheat.

I also noticed some spots of fluid on my boat trailer, which also points to a tranny leak. After work I will get under the car and have a look.

At best this may be new cooler lines along with a beefier cooler, fluid and filter change. At worst it could be a new/rebuilt tranny :-(
gordon is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.