Trans issues. Automatic, 5.2L. -

LinkBack Thread Tools
post #1 of 3 Old 12-09-2013, 10:32 PM Thread Starter
Registered User
1995 ZJ 
Join Date: Oct 2013
Location: New Bedford
Posts: 20
Trans issues. Automatic, 5.2L.

Here's a weird one. Now I don't know much at all about transmissions so that's kind of why I'm here. Now I did a routine fluids check and noticed my trans fluid wasn't reading that I had any at all. Yes the vehicle was running, in neutral, while on a level surface. I did notice a small leak on the cooling lines leading up to the radiator, so far up that I had fluid on the bottom of my front bumper. Here's the weird thing. I didn't notice the fluid was low until I performed the check. The transmission hasn't been behaving weirdly at all. Shifting normal, no overheating issues/grinding or whirring noise. So my question is, is it possible that I do have adequate fluid but something could be making the reading come up wrong? I know it sounds stupid but I'm stumped. And I don't want to add any fluid yet and risk overfilling it and causing unnecessary damage. Thanks all in advance for taking time to read through all this.

timtuttlez3531 is offline  
Sponsored Links
post #2 of 3 Old 12-09-2013, 10:46 PM
Registered User
1997 ZJ 
Join Date: Jan 2009
Posts: 3,138
You might have just been lucky. If it's the OEM dipstick, it should be up to the full line.

On my first ZJ many years ago, I didn't realize you had to check the level in neutral. I always checked it in park. Once I actually read the dipstick and checked in neutral, it was down about a half quart. Like you, I never had any issues or symptoms but I did top it off after that.

JasonStebbins is offline  
post #3 of 3 Old 12-10-2013, 07:58 AM
Registered User
1998 ZJ 
Join Date: Nov 2012
Location: Broken Arrow
Posts: 622
If fluid didn't show up on the dipstick the transmission should have been slipping. Possibly you didn't have the dipstick seated all the way when you checked the level?

kensnelling is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome