Trans issues. Automatic, 5.2L. -
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Trans issues. Automatic, 5.2L.

Jeep Wrangler TJ 8.8 Axle Swap Kit24-Hour Columbus Day Sale from Morris 4x4 Center!!!!The Original 3/8" Ruffstuff Diff Cover!

Unread 12-09-2013, 10:32 PM   #1
Registered User
1995 ZJ 
Join Date: Oct 2013
Location: New Bedford, MA
Posts: 20
Trans issues. Automatic, 5.2L.

Here's a weird one. Now I don't know much at all about transmissions so that's kind of why I'm here. Now I did a routine fluids check and noticed my trans fluid wasn't reading that I had any at all. Yes the vehicle was running, in neutral, while on a level surface. I did notice a small leak on the cooling lines leading up to the radiator, so far up that I had fluid on the bottom of my front bumper. Here's the weird thing. I didn't notice the fluid was low until I performed the check. The transmission hasn't been behaving weirdly at all. Shifting normal, no overheating issues/grinding or whirring noise. So my question is, is it possible that I do have adequate fluid but something could be making the reading come up wrong? I know it sounds stupid but I'm stumped. And I don't want to add any fluid yet and risk overfilling it and causing unnecessary damage. Thanks all in advance for taking time to read through all this.

timtuttlez3531 is offline   Reply With Quote Quick reply to this message
Unread 12-09-2013, 10:46 PM   #2
Registered User
1997 ZJ 
Join Date: Jan 2009
Posts: 3,138
You might have just been lucky. If it's the OEM dipstick, it should be up to the full line.

On my first ZJ many years ago, I didn't realize you had to check the level in neutral. I always checked it in park. Once I actually read the dipstick and checked in neutral, it was down about a half quart. Like you, I never had any issues or symptoms but I did top it off after that.
JasonStebbins is offline   Reply With Quote Quick reply to this message
Unread 12-10-2013, 07:58 AM   #3
Registered User
1998 ZJ 
Join Date: Nov 2012
Location: Broken Arrow, OK
Posts: 623
If fluid didn't show up on the dipstick the transmission should have been slipping. Possibly you didn't have the dipstick seated all the way when you checked the level?

kensnelling is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. is not in any way associated with Jeep or the Chrysler Corp.