Tranny issue; Gov sensor/solenoid or??? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Tranny issue; Gov sensor/solenoid or???

Baseline 4x4 Lifetime Warranty 4340 Chromoly Axle Shaft KiClayton Off Road WJ Long Arm Kits!Clayton Off Road - JK Prototype Gas Tank Skid

Reply
Unread 02-01-2013, 07:07 PM   #1
zachjf
Registered User
1998 ZJ 
 
Join Date: Jun 2008
Location: Portland, Oregon
Posts: 1,067
Tranny issue; Gov sensor/solenoid or???

Ever since I've owned my 5.9 I've had a weird issue during full throttle 1-2 upshifts where the transmission wont shift quick enough to keep the engine from hitting the fuel cutoff/rev limiter so it bucks and sputters, this is a different sputter than the "less than 1/4 tank around corners" fuel starvation issue tho. Up until now I've just dealt with it and either dont give it full throttle or I just back off a bit right before redline then hammer it back down and I'm fine on the 2-3 shift and into O/D. I'm not getting any codes, the tranny doesnt "hunt" gears at partial throttle and the fluid was changed like 10k ago and looks/smells good so I'm wondering if its still possibly a gov sensor/solenoid issue or if I should be looking elsewhere?

__________________
Needs parts?
PM Kolak or kolak@kolakperformance.com
zachjf is offline   Reply With Quote
Unread 02-01-2013, 08:14 PM   #2
newfieZJ
Registered User
1995 ZJ 
 
Join Date: May 2008
Location: , Alberta
Posts: 6,453
I think a little tweeking with that throttle cable and you'd be golden . IIRC , move it a notch or 2 back for quicker shifting .
newfieZJ is offline   Reply With Quote
Unread 02-01-2013, 08:47 PM   #3
4Slow9erHybrid
Registered User
1997 ZJ 
 
Join Date: May 2008
Location: Hopkinton, MA
Posts: 691
adjusting the bands might help as well...
__________________
1997 JGC Laredo 4.0 4x4 99900mi * 0W30 German Castrol since 75k * 225/75/R15 Firestone Destination AT on Ravine rims * winter 235/75/R15 Bridgestone Blizzak DM-V1 * UC suspension * Monroe Reflex Monotube shocks * factory skids * KOR steering brace * rear Addco SB * Magnaflow cat and cat back system * complete 5.9 interior
4Slow9erHybrid is offline   Reply With Quote
Unread 02-01-2013, 08:49 PM   #4
zachjf
Registered User
1998 ZJ 
 
Join Date: Jun 2008
Location: Portland, Oregon
Posts: 1,067
Quote:
Originally Posted by newfieZJ View Post
I think a little tweeking with that throttle cable and you'd be golden . IIRC , move it a notch or 2 back for quicker shifting .
Yea, I forgot to mention I've tried that, both loosened it up till it was shifting really early up and down as well as tightened so every gear banged even at part throttle and it was annoying to drive. I'm honestly at a loss since the setting I have it at now results in firm but not rough up/downshifts and the tranny shifts great everywhere except full throttle on the 1-2
__________________
Needs parts?
PM Kolak or kolak@kolakperformance.com
zachjf is offline   Reply With Quote
Unread 02-02-2013, 08:43 AM   #5
4Slow9erHybrid
Registered User
1997 ZJ 
 
Join Date: May 2008
Location: Hopkinton, MA
Posts: 691
You need to adjust the bands.

http://www.jeepforum.com/forum/f13/t...09/index3.html
__________________
1997 JGC Laredo 4.0 4x4 99900mi * 0W30 German Castrol since 75k * 225/75/R15 Firestone Destination AT on Ravine rims * winter 235/75/R15 Bridgestone Blizzak DM-V1 * UC suspension * Monroe Reflex Monotube shocks * factory skids * KOR steering brace * rear Addco SB * Magnaflow cat and cat back system * complete 5.9 interior
4Slow9erHybrid is offline   Reply With Quote
Unread 02-03-2013, 12:17 PM   #6
Spanovich008
Registered User
1995 ZJ 
 
Join Date: Nov 2012
Location: Morgantown, WV
Posts: 58
if it's not throwing any codes, then it's probably not the Pressure Sensor and/or Solenoid. Sounds like your bands need adjusted.
__________________
don't be afraid to put the "fun" in "dis-functional"
Spanovich008 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.