Tough Electrical Issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 10-11-2011, 12:01 PM Thread Starter
Steveman09
Registered User
1997 ZJ 
 
Join Date: Oct 2011
Location: beaverton
Posts: 2
Tough Electrical Issue

So I bought this 97 ZJ few months ago and everything was good until recently it developed a strange Battery Drain.

I'm on my 2nd battery to no avail.

I recently found that after the key is shut off and removed the HVAC Auto unit after about 1 minute comes on but the screen is very dim, also the compass overhead and VIC come on! The VIC says rear lamp failure for about 30 seconds then goes off, then comes on again in a few minutes and says the same thing.

Also the Blower comes on with the HVAC unit as well, if I turn the HVAC switch off the blower and HVAC unit goes off and stays off, but the VIC and overhead compass and auto dim mirror stay on!

This is driving me nuts and runs the battery down.

When I start it up with the key all systems return to normal until the next key off.

Any idea's?

Steveman09 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-11-2011, 12:12 PM
melk
Registered User
1996 ZJ 
 
Join Date: Sep 2009
Location: Charlotte
Posts: 2,890
Quote:
Originally Posted by Steveman09
So I bought this 97 ZJ few months ago and everything was good until recently it developed a strange Battery Drain.

I'm on my 2nd battery to no avail.

I recently found that after the key is shut off and removed the HVAC Auto unit after about 1 minute comes on but the screen is very dim, also the compass overhead and VIC come on! The VIC says rear lamp failure for about 30 seconds then goes off, then comes on again in a few minutes and says the same thing.

Also the Blower comes on with the HVAC unit as well, if I turn the HVAC switch off the blower and HVAC unit goes off and stays off, but the VIC and overhead compass and auto dim mirror stay on!

This is driving me nuts and runs the battery down.

When I start it up with the key all systems return to normal until the next key off.

Any idea's?
Fuses and relays, ground straps, PCM wires. Good luck.
melk is offline  
post #3 of 6 Old 10-11-2011, 10:24 PM
patchman5401
Registered User
 
Join Date: Oct 2011
Location: Regina
Posts: 1
You may want to check a thread titled 1998 ZJ Electrical Problems by Hemimonster425 a little farther down the list. Sounds like you may have the same kremlin that he did!
patchman5401 is offline  
post #4 of 6 Old 10-12-2011, 09:28 AM Thread Starter
Steveman09
Registered User
1997 ZJ 
 
Join Date: Oct 2011
Location: beaverton
Posts: 2
Update : Got it figure out!


So here's the deal, I figured out whats going on today and fixed it as well!

So I found a water leak that was pretty severe on the passenger floor, under closer inspection I removed the fuse box/relay center assembly to find it completely soaked and full of water!!!

I removed the fuse box and took it apart and dried it out with a blow dryer, now on to the water leak issue....

I traced the water leak to blocked Cowl Drains causing overflow into the heater fresh air duct!!! so I cleaned the cowl all out and re tested no more leaks! Also for good measure I read somewhere about the antenna leak issue so I sealed that grommet up as well.

I removed all the interior and drained the floor pans with a drill then replugged the holes, removed the seats and carpet and sent to detail shop for cleaning.

All is well now

Leaks fixed and no more electrical issues!
Steveman09 is offline  
post #5 of 6 Old 10-12-2011, 10:27 AM
moggie99
Registered User
1996 ZJ 
 
Join Date: Sep 2011
Location: Al Ain
Posts: 684
Well done - 100% success at minimal expense is the perfect result.

Richard Moss
'96 ZJ 4L auto, '95 XJ 4L manual, 2000 Nissan Patrol Y61
In the UK: 1969 MGC GT
moggie99 is offline  
post #6 of 6 Old 10-13-2011, 05:29 AM
savannahzj
Registered User
1998 ZJ 
 
Join Date: Apr 2011
Location: savannah
Posts: 191
When you say you cleaned the cowl drains, can you be more specific? Location, method, etc. We have had a ton of rain here and I just experienced virtually the same symptoms. Thanks for your help.
savannahzj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
electrical issue 95orvisgrand ZJ Grand Cherokee Forum 35 09-18-2010 05:56 PM
AC Electrical Issue SylvesterCat ZJ Grand Cherokee Forum 1 08-05-2010 10:23 AM
Electrical issue??? 97jeepgurl ZJ Grand Cherokee Forum 2 04-16-2010 09:37 PM
Electrical issue, again! newberrykc ZJ Grand Cherokee Forum 12 03-08-2010 05:41 AM
Electrical Issue jdminton ZJ Grand Cherokee Forum 13 03-21-2008 11:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome