Timing 4.0 - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 12-10-2011, 10:11 AM Thread Starter
Registered User
1998 ZJ 
Join Date: Aug 2010
Location: West Virginia
Posts: 161
Timing 4.0

Ok so I recently had my 1998 jeep grand cherokee 4.0 rebuilt. Now it is running but once you drive it for a lil while the check engine light comes on and gives an upstream o2 sensor code. But when hooked to a scan tool both o2 sensors are going crazy. We checked the timing at the distibutor and it shows to be about a tooth out but if you put it were it is suspoded to be it wont run. The scan tool says it is firing at 14-17 degrees before top dead center at idle. Can anyone tell me what it is suspoded to fire at.

Flat_Black_ZJ is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
ZJ 5.2 timing (need help) !!!!!!!!!!!! johncsmith711 ZJ Grand Cherokee Forum 4 03-05-2011 11:21 PM
timing ? jim75 ZJ Grand Cherokee Forum 2 01-18-2009 08:13 AM
timing ??? sdr93 ZJ Grand Cherokee Forum 3 12-11-2005 06:44 AM
Timing Raven ZJ Grand Cherokee Forum 1 11-17-2004 08:59 AM
98 4.0 Timing smiley ZJ Grand Cherokee Forum 2 11-20-2003 02:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome