Ticking coming from the glove box relay/fuse - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Ticking coming from the glove box relay/fuse

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 09-30-2013, 02:36 PM   #1
lanks20
Registered User
 
Join Date: Sep 2013
Posts: 10
Ticking coming from the glove box relay/fuse

So I baught me a 95 ZJ and I'm currently fixing all the little problems. I can't figure this one out tho, whenever my doors are open one of the relays or fuses whatever it is in the glove box ticks nonstop until I close the doors again.

lanks20 is offline   Reply With Quote
Unread 09-30-2013, 03:00 PM   #2
Wheelin98TJ
JEEP FREAK
 
Wheelin98TJ's Avatar
1998 TJ Wrangler 
 
Join Date: Apr 2004
Location: , Southeast MI
Posts: 24,173
Moved to ZJ Forum.

The forum you posted in (JeepForum Announcements & Comments) is for questions about and help with the forum.
Wheelin98TJ is online now   Reply With Quote
Unread 09-30-2013, 03:40 PM   #3
95GCL
Registered User
1995 ZJ 
 
Join Date: Jul 2013
Location: catharpin, VIRGINIA
Posts: 230
Should've put both questions in one topic. The ticking, for what I found in my ZJ still, is from having a low battery.
95GCL is offline   Reply With Quote
Unread 09-30-2013, 04:04 PM   #4
JeepNicholson
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Burbank, OH
Posts: 755
Quote:
Originally Posted by 95GCL View Post
Should've put both questions in one topic. The ticking, for what I found in my ZJ still, is from having a low battery.
^ this x2

It happens because the battery doesn't have enough power to "shift" the relay, so it just keeps clicking
JeepNicholson is offline   Reply With Quote
Unread 09-30-2013, 06:26 PM   #5
lanks20
Registered User
 
Join Date: Sep 2013
Posts: 10
I thought it could have been the battery since it still has the one that came with it. Another thing that's weird is that the auto door locks don't work unless the doors are closed too. Think it could be the same issue?
lanks20 is offline   Reply With Quote
Unread 09-30-2013, 06:38 PM   #6
JeepNicholson
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Burbank, OH
Posts: 755
Quote:
Originally Posted by lanks20 View Post
I thought it could have been the battery since it still has the one that came with it. Another thing that's weird is that the auto door locks don't work unless the doors are closed too. Think it could be the same issue?
That sounds more like an issue with the door wiring harness, probably loose or broken wire.
JeepNicholson is offline   Reply With Quote
Unread 09-30-2013, 07:22 PM   #7
Pugulis
Registered User
1996 ZJ 
 
Join Date: Aug 2010
Location: Long Island, New York
Posts: 1,013
Does it start? I'd say it's a low battery or bad battery connection. Do a good thorough cleaning of the post and clamp and you'll be fine. Unless the batter is shot.
__________________
[_][]☺[][][]☺[][_] 96' Grand Cherokee Laredo 265,000 miles and still going strong.
Pugulis is offline   Reply With Quote
Unread 09-30-2013, 07:36 PM   #8
Higgins
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: st charles, IL
Posts: 69
when checking the battery connections, check both the terminal on the alternator, as well as the #4 cable between the battery and the alternator!!!!!

Earlier this yr, I was fighting a similar problem. The alternator connection looked good, but I cleaned it anyhow, as well as the battery connections. The jeep left me stranded in a parking lot. Once I got it home everything looked OK. But when I was under the Jeep, the RED cable between the alternator and the battery was swollen............. The cable jacket had been kicked, and the copper cable was deteriorating .... Was an easy fix! Was dump that I didn't see that previously!!!

AL
Higgins is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.