Throttle cable part number and source? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 04-13-2013, 05:56 PM Thread Starter
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 2,019
Throttle cable part number and source?

Replaced the freeze plugs on the Jeep today and noticed that the throttle cable is bad. The outer sheath is broken under the rubber outer cover. I had my sister push the pedal and I could see the inner cable pulling out to the side. I used a bunch of zip ties to hold it together for now but I need to replace it. I searched the forum and googled a little to try and find one but I'm striking out.

Any one have a Jeep part number and a place to order one? I'm out of town for a week so I can order it and replace it when I get back.

93 ZJ, 4.0, 42RE FWIW

zjosh93 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-13-2013, 08:06 PM Thread Starter
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 2,019
Never mind, Crown makes one. Found it from several sources, PN 52078530
zjosh93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome