Thermostat stuck shut? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Thermostat stuck shut?

ZONE 4.25" combo lift for TJ available at Rockridge4wG2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ ChANOTHER Rockridge4wd Creation!! Spare Tire Carrier Delete

Reply
Unread 02-29-2004, 12:03 AM   #1
Choff
Registered User
 
Join Date: Nov 2003
Location: Fargo, ND
Posts: 17
Thermostat stuck shut?

How does one tell if the thermostat it stuck shut? There's been a lot of steam coming off of my engine (93 4.0L) lately, but it's really wet here (lots of "lakes" from melting snow)... well, after driving it long enough to get totally warm, I checked the radiator cap, not hot... opened it, no pressure and the antifreeze wasn't more than lukewarm. WHen I start the thing after it's been sitting for a while a big old cloud of steam comes off then it tapers back. This could be from water dripping down on something hot, but it comes rolling off as soon as the engine fires (fan blowing it around?)

The temp gauge reads abotu 210 when it's warmed up, which is where it's always been. The heater works.

Is the temp sensor in the engine or the radiator?

THanks
Chris


Last edited by Choff; 02-29-2004 at 12:06 AM..
Choff is offline   Reply With Quote Quick reply to this message
Unread 02-29-2004, 09:19 AM   #2
Wondy
Registered User
 
Join Date: Feb 2004
Location: Pennsylvania
Posts: 6
Its prob not the thermostat because in my 94 4.0 my thermostat go stuck shut and the engine ran at about 240-260 and i had no heater. It costs about 7 bucks for the thermostat and gasket.
Wondy is offline   Reply With Quote Quick reply to this message
Unread 03-01-2004, 11:13 AM   #3
94ZZJJ
Registered User
 
Join Date: Jan 2004
Location: US PA
Posts: 51
Mine stuck shut a little while ago(v8). After a minute of idling the top rad hose became hard while cold and a little while later all the hoses started to leak past the clamps and the bulkheads for the atf cooler in the rad started leaking and made a puddy. I fixed it w/ a new stat and just put a new 3row hd all metal rad in it

On a v8 there are 2 sensors. One for the gauge and one for the ecu. The ecu sensor is next to the tsat housing and chiltons says the gauge is on the left side of the engine(?). I replaced the sensor by the stat thinking it was for the gauge and it wasn't.

Make sure you still have coolant
94ZZJJ is offline   Reply With Quote Quick reply to this message
Unread 03-01-2004, 12:27 PM   #4
Choff
Registered User
 
Join Date: Nov 2003
Location: Fargo, ND
Posts: 17
Yeah, I don't think it's the thermostat. The heater works fine and it doesn't overheat. There is antifreeze...

I hope the steam is just from all the water around here. As many nasty tricks as that thing has been playing lately I am tired of it.

Any idea how to adjust the idle (if possible)? I replaced the O2 sensor and it runs a lot better... but now it idles at like 1700 rpms, which makes the tires squeak when you put it in gear...
Thanks
Chris
Choff is offline   Reply With Quote Quick reply to this message
Unread 03-02-2004, 09:53 PM   #5
Saleen4971
Registered User
 
Join Date: Jan 2004
Location: Setauket, LI
Posts: 236
thats probly yout IAC. 60$ i think is retail price for one. two torx head screws (#25? i think?) i jsut had to replace mine at almsot 126k
__________________
1998 5.9 Limited
ET: 14.3@94MPH

Engine/Trans
- Full Kolak Exhaust (ML's FM70) - FIPK2 - APS 52mm TB - MSD Blaster SS - A3923's - Magnecor's - MP ECU - 180 robertshaw t-stat - Relocated IAT - E.H. M1 - B&M Trans Cooler

Susupension/Brakes
- Addco 1.25" Military front & 7/8" rear sways - Edelbrock IAS shocks - OME S.S - Stilens Front & Rear

Coming Soon :
Level10 Stage 3 46RE - WJ knuckle conversion
Saleen4971 is offline   Reply With Quote Quick reply to this message
Unread 03-03-2004, 07:22 AM   #6
Choff
Registered User
 
Join Date: Nov 2003
Location: Fargo, ND
Posts: 17
Quote:
Originally Posted by Saleen4971
thats probly yout IAC. 60$ i think is retail price for one. two torx head screws (#25? i think?) i jsut had to replace mine at almsot 126k
What's the long name for that unit and where's it located? In the throttle body?
Thanks!
Chris
Choff is offline   Reply With Quote Quick reply to this message
Unread 03-11-2004, 03:54 PM   #7
KyleM
Registered User
 
Join Date: Mar 2004
Location: Georgia
Posts: 31
Quote:
Originally Posted by Choff
What's the long name for that unit and where's it located? In the throttle body?
Thanks!
Chris
Idle air control valve (or motor). Yes, it is located on the side of the throttle body.
KyleM is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.