JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   Thermostat issue (http://www.jeepforum.com/forum/f13/thermostat-issue-1531318/)

jchambers224 06-02-2013 09:53 AM

Thermostat issue
 
We have had 3 different thermostats in our 95 GC and cant get any of them to run anywere close to the 195-210 mark. Whats the deal?

ZeeJay1997 06-02-2013 10:22 AM

try changing the coolant temp sensor on top of and at the back of the head, or first just try cleaning and reseating the connector

dnuccio 06-02-2013 10:52 AM

the gauge is probably off. when my gauge reads 210, an infrared thermometer shot at the cylinder head reads 165

JasonStebbins 06-02-2013 10:53 AM

Why are you replacing the thermostat? Are you experiencing overheating issues? The stock thermostat is 195 degrees. Your 4.0L should run at 210 all day long.

StPaul59 06-02-2013 07:49 PM

Are you using one of those 'Fail Safe' thermostats? They are junk.

zjosh93 06-02-2013 10:42 PM

Agree that FailSafe are crap, so are the Robert Shaw hi flow thermostats, used to be the best but I had two fall apart in my engines.

As stated above we could use more info. Are you over heating, is the gauge doing weird things, anything else going on? Bad fan clutch? Any other engine issues?

Dubfire98 06-03-2013 11:03 AM

I had a similar problem on my 5.2l. Temp kept going up and down randomly. even spiked once then suddenly fell back down to 210. Needless to say i tried the failsafe therm, JUNK! They actually lock open once they hit they designed temp and they STAY open until replaced. My problem turned out to be the fan clutch. The resistance test didnt help me any cause i still had what seemed to be a good amount of pull on it, but sure enough it was bad. Today going with a new OEM thermostat, and just a quick compression test to make sure my head gasket is still good. Coolant is looking a lil cloudy, but not using/leaking oil or coolant, no coolant mixed with oil, not burning white smoke, but still weird colored coolant.

jchambers224 06-04-2013 06:49 PM

Problem solved! It was the coolant temperature switch. We are having problems with it smoking when it is sitting at an idle. When we take off again it smokes. Noticed it wasnt runnimg at approp temp so thought it might be that. Still smoking though after this was fixed. I have another thread regarding this matter now.


The time now is 10:42 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.