Temperature gauge, reading low? Inaccurate? Fixed - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 18 Old 11-13-2013, 05:46 AM
Yoda95
Registered User
1995 ZJ 
 
Join Date: Jun 2013
Location: Marietta
Posts: 45
I have this same problem, running way cold. I have decided to change the sending unit, but are the part numbers the same for front and rear on a 95 4.0...and which one do I replace? Both? Front is for PCM, rear is for gauge...but which is the cold run issue? Thanks for the clarification. They look the same for all part numbers listed.

Edit: I re-read the post and realize that the rear one is the only one listed here...but what is the part number for the sensor up front?

Which one has the two prongs, and which one has the one prong?

I read elsewhere that if the sensor up front is bad, I would get CEL and codes, and if the rear is bad the gauge may not function at all. The gauge seems to function, it just stays way cold.

Would the front temp sensor (as opposed to rear sending unit) cause it to run really cold? I am not up for changing the thermo just yet, I was hoping it is just the front sensor...

Any information would be great, thanks!

Yoda95 is offline  
Sponsored Links
Advertisement
 
post #17 of 18 Old 04-30-2016, 02:16 PM
tetatdo
Registered User
1994 ZJ 
 
Join Date: Aug 2003
Location: Pasadena, CA
Posts: 179
is there a trick to getting the sender out from the back of the head? I tried with a 13 mm and it doesnt fit as the valve cover is in the way, i tried a 9/16 and it's too big.

I did manage to get a 13mm wrench around it but the damn brass sensor just warped and now nothing fits around it. Do I need to pull the valve cover to get this thing out?!

______________________
Tetatdo
94 ZJ/Hunter Green/4.0L/242 - 05 M3 - 01 M-coupe
tetatdo is offline  
post #18 of 18 Old 05-01-2016, 10:29 AM
tetatdo
Registered User
1994 ZJ 
 
Join Date: Aug 2003
Location: Pasadena, CA
Posts: 179
dude! thanks for this thread, I had the exact same issue and changed the temp sender and it fixed the issue. I also have a DRB II and spent some time comparing what the guage reads to what the ECU sees. Its kind of interesting. A little above the second left line is 190 on my ZJ. right at the second line is about 180.

______________________
Tetatdo
94 ZJ/Hunter Green/4.0L/242 - 05 M3 - 01 M-coupe
tetatdo is offline  
Reply

Tags
temperature gauge , temperature sensor

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Outside Temperature Reading fred99x WK Grand Cherokee & XK Commander Forum 11 09-22-2009 01:49 PM
WK temperature reading 2007GC Overland WK Grand Cherokee & XK Commander Forum 0 10-18-2007 10:35 AM
Outside Temperature Reading... sno543 ZJ Grand Cherokee Forum 9 07-22-2006 05:59 PM
Temperature guage not reading? Rock1127 ZJ Grand Cherokee Forum 6 08-07-2005 04:56 PM
Temperature reading, coolant level denise_109 ZJ Grand Cherokee Forum 3 02-10-2005 07:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome