TCM, 93 Grand cherokee. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > TCM, 93 Grand cherokee.

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineKrawlOff-Road.com Jeep Beach Sale

Reply
Unread 07-16-2013, 10:07 PM   #1
93fourGC
Registered User
 
Join Date: Jul 2013
Location: dawson creek, bc
Posts: 5
TCM, 93 Grand cherokee.

Hey everyone, I've got a 1993 grand cherokee 4.0

It hasnt been driving in the drive gear for a bit now, so ive been looking into what it is, ive read that it could be the TCM, so i found the Tcm under my steering wheel area, took it out, and nothing changed with the jeep so i figured thats what the problem is..

now my problem is, Where the eff can i buy a TCM other then a Junk yard?

I geuss i should specify, i can drive it in 1, 2 and drive, but i have no overdrive and when im at a stop and start in drive, it revs but accelerates slow like its stuck in 3rd.

It is an automatic.

and before anyone says 'use the search' I did. for a week ish. and all ive found is that it could be TCM or speed sensors?

Thanks to anyone that can help with any of this.

93fourGC is offline   Reply With Quote
Unread 07-16-2013, 10:52 PM   #2
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 998
I looked around awhile back to try and find someone who sold them and I did find someone though I can't recall at the moment who. It may have been one of the chain parts places. I think I googled around a lot and ended up googling the stock part number and finding someone.

They were like $180 though IMS so I just got another at a junkyard. $30 and it fixed my problem. I had the limp mode even after replacing the sensor and solenoid. JY TCM fixed it. FWIW I used a 94 TCM and a 93 TCM and they both worked the same in my Jeep. 4.0 42RE.

I figure it's probably bad caps like the PCM but I haven't gotten around to replacing them to see if it makes a difference.
zjosh93 is offline   Reply With Quote
Unread 07-18-2013, 12:07 PM   #3
93fourGC
Registered User
 
Join Date: Jul 2013
Location: dawson creek, bc
Posts: 5
Limp mode? is that what mine is, where it can be manually shifted but not driven in drive?

Ill search up the part number though, thanks a lot, and ill try the 94 one if I cant find a 93..My jeep was actually made in june of 1992, but its 'called' a 93
93fourGC is offline   Reply With Quote
Unread 07-18-2013, 12:35 PM   #4
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 998
Limp mode starts you out in 2nd and will let you shift to 3rd but that's all you get. Is you overdrive light on? You can pull trans codes using the same procedure to check the check engine light. Turn the key on-off-on-off-on within five seconds and it will flash codes.
zjosh93 is offline   Reply With Quote
Unread 07-18-2013, 02:07 PM   #5
93fourGC
Registered User
 
Join Date: Jul 2013
Location: dawson creek, bc
Posts: 5
Ill check my codes again later, I forget now which ones came up last time I did it, but I am got the day off work today so ill find a tcm hopefully at a scrap yard, then im picking up some steel to make bumpers out of.. So if I find a tcm and it doesn't work ill scan the jeep and let ya know, thanks a lot for your help.
93fourGC is offline   Reply With Quote
Unread 07-18-2013, 02:08 PM   #6
93fourGC
Registered User
 
Join Date: Jul 2013
Location: dawson creek, bc
Posts: 5
sorry, my od light isn't on, and I don't get 2nd to 3rd, If I start in drive im pretty sure its just 3rd with no od. I can shift from 1-2 to 3rd to drive though
93fourGC is offline   Reply With Quote
Unread 07-18-2013, 02:46 PM   #7
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 998
Sorry, yes that's right. Limp mode gets you 2nd but you have to move the shifter to 1 or 2 manually to get it. D just gets to 3rd. If your OD light is out I would suspect the TCM but it could be something else. I remember there are a couple good threads on here about it that helped me out.
zjosh93 is offline   Reply With Quote
Unread 07-18-2013, 08:04 PM   #8
93fourGC
Registered User
 
Join Date: Jul 2013
Location: dawson creek, bc
Posts: 5
Yeah, ive read a few threads saying speed sensors, but I figured I might as well start with the tcm.

couldn't find one at any of the 3 junk yards ! great..
93fourGC is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.