stumbling idle after warmed up - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > stumbling idle after warmed up

Premium LED Lighting by VISION X, Proudly sold at ROCKRIDGFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 08-24-2013, 02:14 PM   #31
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,346
Quote:
Originally Posted by JaneLee View Post
remove the o2 sensor
if you havent disconnected the o2 sensor, nevermind about checking the ignition system. the object is to get it out of the sensor circuit to make the PCM use default fuel strategy.

ZeeJay1997 is offline   Reply With Quote
Unread 08-25-2013, 08:47 AM   #32
JaneLee
Registered User
1994 ZJ 
 
Join Date: Aug 2013
Location: Richmond, IN
Posts: 35
i previously disconnected the o2 sensor with no issues found before i unscrewed it to test the CAT. It threw codes for every injector. I did look at the ignition coil and guess what? It does have a large crack in it. It does get very hot when the engine warms up and starts it's tricks. Problem found? previously had a buddy look at it and he missed it, now he thinks that's probably the problem?
JaneLee is offline   Reply With Quote
Unread 08-25-2013, 08:50 AM   #33
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,346
Quote:
Originally Posted by JaneLee View Post
Problem found?
Yes, that would be reason for replacement. Whether or not it is your only problem, on the ZJ will divulge those secrets.
ZeeJay1997 is offline   Reply With Quote
Unread 08-25-2013, 08:56 AM   #34
JaneLee
Registered User
1994 ZJ 
 
Join Date: Aug 2013
Location: Richmond, IN
Posts: 35
ok lol Will see then thanks
JaneLee is offline   Reply With Quote
Unread 08-29-2013, 09:19 PM   #35
wwilly1968
Registered User
1993 ZJ 
 
Join Date: Jan 2012
Location: walker, w.v.
Posts: 11
ok

Last edited by wwilly1968; 08-30-2013 at 05:24 AM..
wwilly1968 is offline   Reply With Quote
Unread 08-29-2013, 09:28 PM   #36
JaneLee
Registered User
1994 ZJ 
 
Join Date: Aug 2013
Location: Richmond, IN
Posts: 35
OK guys. replaced the ignition coil, y'all were right. it was cracked motor side and bad. now she's happy. thank you guys so much
JaneLee is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.