struggling ! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > struggling !

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: Wranger BRIGHT License Plate LED! Just $3! Great valueThanksgiving/Black Friday/Cyber Monday Deals at JeepinOutf

Reply
Unread 07-12-2009, 06:08 PM   #1
BOILERMAKER667
Registered User
1994 XJ Cherokee 
 
Join Date: Jul 2009
Location: WV
Posts: 2
struggling !

my 94 grand cherokee larado has seen its better days, iv decided to fix ALL the probs, and have done alot of work to it over the past 6 months, replaced/fixed transmission, transfer case, alt, battery, injectors, computer, brakes, shocks, rotors, idle pos sen. The problem i cant seem to find a cure for is......jeep will start and idle fine. will run perfectly up to 3000rpm then it sputters. lack of power. im stumped. im not a certified mech but i can figure out most everything...but not this time.....HELP PLEASE....

BOILERMAKER667 is offline   Reply With Quote Quick reply to this message
Unread 07-12-2009, 06:49 PM   #2
kc8ztw
Registered User
1993 ZJ 
 
Join Date: Dec 2008
Location: Rockford, Mi
Posts: 193
could be a fuel issue. get a fuel pressure gauge and hook to inspection value on fuel rail and watch your pressures.
is this 3000 rpms under load (like while driving) or in park/neutral?
kc8ztw is offline   Reply With Quote Quick reply to this message
Unread 07-12-2009, 06:53 PM   #3
gatorayde
Registered User
1999 WJ 
 
Join Date: Jun 2008
Location: Crystal Lake, IL
Posts: 3,334
I would agree that it sounds like a fuel problem. Have you replaced the fuel filter/fuel pump?
gatorayde is offline   Reply With Quote Quick reply to this message
Unread 07-12-2009, 08:43 PM   #4
BOILERMAKER667
Registered User
1994 XJ Cherokee 
 
Join Date: Jul 2009
Location: WV
Posts: 2
at idle it dont seem to do it, never really reved it up hard. yes, it does it under normal driving conditions. i havnt changed anything on the fuel system yet.
BOILERMAKER667 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.