stinkin brake light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > stinkin brake light

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 09-19-2009, 05:01 PM   #1
wjchristine
Registered User
2001 WJ 
 
Join Date: Jan 2009
Location: NC
Posts: 59
stinkin brake light

so now my passenger side brake light is being weird. when i turn my running lights on it works fine along with the signal. however, when i hit the brakes the signal works but the whole brake light cuts out. i already replaced the bulbs and there is no code coming up. please help!

wjchristine is offline   Reply With Quote
Unread 09-20-2009, 07:08 AM   #2
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,628
Not trying to be nasty, but try doing as search for this problem, it has been addressed several times. I think it has something to do with the printed circuit boards in the tail light assembly itself.
__________________
Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline   Reply With Quote
Unread 09-20-2009, 08:02 AM   #3
wjchristine
Registered User
2001 WJ 
 
Join Date: Jan 2009
Location: NC
Posts: 59
i tried doing some research so i didnt look stupid asking that but couldnt find anything real close to that. im not real sure what the printed circuit board is. do you mind explaining that?
wjchristine is offline   Reply With Quote
Unread 09-20-2009, 08:57 AM   #4
wjchristine
Registered User
2001 WJ 
 
Join Date: Jan 2009
Location: NC
Posts: 59
Not trying to be nasty, but try doing as search for this problem, it has been addressed several times. I think it has something to do with the printed circuit boards in the tail light assembly itself.

well i feel like a complete idiot. i was having a brain fart. i looked at the circuit board and it was just a matter of lifting up the ground tap. now everything works like nothing was ever wrong.
wjchristine is offline   Reply With Quote
Unread 09-20-2009, 09:41 AM   #5
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,628
Glad to hear you got it fixed.
__________________
Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline   Reply With Quote
Unread 09-20-2009, 09:55 PM   #6
sprocket1200
Registered User
2001 WJ 
 
Join Date: Aug 2007
Location: bc canada
Posts: 172
when you replace the bulbs, make sure you use that electrical grease stuff. worked wonders for our intermittent problems...
sprocket1200 is offline   Reply With Quote
Unread 09-21-2009, 10:33 AM   #7
Double E
2000 Laredo V8
 
Double E's Avatar
2000 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 3,266
It'll work fine for about 2 months.

http://www.jeepforum.com/forum/f13/t...roblem-831749/
__________________
2000 Laredo 4.7L Selec-Trac. 177K miles, Leather, 245 tires, tow package, crappy CD changer, full size spare, roof cross-rails & sunroof.
Changes & fixes: Rear Addco sway bar & greasble bushings, upgraded headlights, upgraded tail lights, new hood struts (replaced 2X), new rear hatchglass struts, new radiator (replaced 3X), new oil pressure sending unit (replaced 4X), 2 new speed sensors, 2 new door lock actuators, new ignition key cylinder, chrome front tow hooks, Mobil 1 Synthetic 5/30, Purolator Pure One oil filter, EBC slotted & dimpled rotors, EBC Greenstuff pads, new front shocks (replaced 3X), new rear shocks (replaced 2X), new IRO steering stabilizer, new timing chain cover, new water pump, thermostat, new thermostat housing, new high pressure power steering hose, Michelin-X radials, new sunroof assembly, new single-piece lug nuts, new exhaust manifold studs & gasket on driver's side, new Durango alternator. Jeepforum.com sticker, Visit cobaltboatsforum.com when you can!
Double E is offline   Reply With Quote
Unread 09-23-2009, 12:45 AM   #8
sprocket1200
Registered User
2001 WJ 
 
Join Date: Aug 2007
Location: bc canada
Posts: 172
mine have worked fine for nearly a year
sprocket1200 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.