Still need help.....jeep won't start.. - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 22 Old 06-24-2011, 09:00 AM Thread Starter
nickm_03
Registered User
1997 ZJ 
 
Join Date: Feb 2011
Location: Amboy
Posts: 55
Still need help.....jeep won't start..

So last thursday as i left work, i drove through a puddle at about 20mph. immediatley after the jeep died, no sputtering (as would occur if the fuel pump went out or i ran out of gas) it just cut out. I got out and checked underneath and the four wires going into the O2 sensor were ripped out and wrapped around my driveshaft. The wires must have came loose from the clip above the driveshaft and ripped out. Those would not cause it to not start though. I tried turning it over and the battery would turn but it would not start. I know its not the starter because i've had to replace the starter on my Ranger 3 times. We checked all the fuses and all of them were in check. When we checked the fuel pump, it would stay on to build up pressure and then it would not kick off, it just stayed on. There is fuel coming to the engine but the gas gauge on the dash reads that the jeep is empty. Thats not possible because i put $60 in before work. I had to have it towed back to my house unfortunately. When we got it home i pulled a plug wire out with a spark plug to test if it was sparking. no spark. I haven't opened the disributor cap yet but I have heard that if that rotar gets wet it would cause it not to start. I think im also gonna get a code reader to see if that will give me a code as to what is wrong. I will probably buy a set of new plugs as well. Let me know if you have any helpful thoughts. Thanks


1997 Jeep Grand Cherokee Laredo 4.0L I6 - Gray
nickm_03 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 Old 06-24-2011, 09:29 AM
t0ast3d
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2004
Location: Southern Ontario
Posts: 99
4.0L or 5.2L? CEL on? You need to get the codes. Key in ignition: 3 "on/offs" ending on "on" should display any codes stored.

Either way, check cap, rotor, plugs, wires. Replace if you have the $100 that stuff will cost.

If it still doesnt start, I'd remove the ignition coil (2 bolts, 30 seconds) and inspect for cracks. Replace if cracked (~$30).

After that, you're looking at camshaft position sensor (disc inside of distributor), crankshaft position sensor (under jeep, on top of bell housing PIA), ASD relay and then the computer.

A failure of any of these things can result in no-start condition.
t0ast3d is offline  
post #3 of 22 Old 06-24-2011, 09:44 AM Thread Starter
nickm_03
Registered User
1997 ZJ 
 
Join Date: Feb 2011
Location: Amboy
Posts: 55
its the 4.0L I6. no spark from plugs, ill pop open the cap in a bit see if its wet in there. CEL?

1997 Jeep Grand Cherokee Laredo 4.0L I6 - Gray
nickm_03 is offline  
post #4 of 22 Old 06-24-2011, 09:55 AM
t0ast3d
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2004
Location: Southern Ontario
Posts: 99
CEL = Check Engine Light. If lit, it means that it is storing one or more fault codes.

Turn key off/on three time ending in the on position and the odometer will read out 2 digit codes. Write em down. 55 means end of codes.
t0ast3d is offline  
post #5 of 22 Old 06-24-2011, 09:58 AM Thread Starter
nickm_03
Registered User
1997 ZJ 
 
Join Date: Feb 2011
Location: Amboy
Posts: 55
Well it was on before, but i think it was on because of the bad battery. i replaced that and now its off. but it wouldnt be on if it wont start up. after i replaced the battery its off

1997 Jeep Grand Cherokee Laredo 4.0L I6 - Gray
nickm_03 is offline  
post #6 of 22 Old 06-24-2011, 10:14 AM
t0ast3d
Registered User
2000 XJ Cherokee 
 
Join Date: Nov 2004
Location: Southern Ontario
Posts: 99
It takes 30 seconds and it's free. I recommend you see it if throws any codes...If there arent, it will show 55.

I'd move to the cap, rotor and wires from there.
t0ast3d is offline  
post #7 of 22 Old 06-24-2011, 10:21 AM Thread Starter
nickm_03
Registered User
1997 ZJ 
 
Join Date: Feb 2011
Location: Amboy
Posts: 55
Ya i planned on running up to o'reillys or autozone bc they both rent them out. ill see if i get any codes from them and then ill go from there thanks

1997 Jeep Grand Cherokee Laredo 4.0L I6 - Gray
nickm_03 is offline  
post #8 of 22 Old 06-24-2011, 08:44 PM
MaintMech
Old and in the way
 
MaintMech's Avatar
1996 ZJ 
 
Join Date: Feb 2011
Location: Farmington
Posts: 619
Start with fixing the broken wires from the O2 sensor. These are important to the PCM and will cause your no start.

Disconnect the battery and reset the PCM after you've repaired the wires.

'96 Grand Laredo, 4.0, Stock, Daily Driver

I fought Oracle and Oracle won!

Originally Posted by coralman
If the faith isn't there,the doubt is.
MaintMech is offline  
post #9 of 22 Old 06-25-2011, 01:35 PM
Oldfrog
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 5,092
When the wires wrapped...they shorted and a fuse blew in the main fuse box that's under the hood. There is also a shut-off relay in there, as I recall. Mine did the same thing when I hit something on the interstate. Cost me $150 to tow it home...dang it. I replaced the fuse, taped up the wires and it started. Duh !

2007 5.7 Hemi, Ltd. QD II -
1997 ZJ, 4,0 select trac, Up country, track lok.
Oldfrog is offline  
post #10 of 22 Old 06-25-2011, 01:44 PM
98BlackZJ
Registered User
1998 ZJ 
 
Join Date: Sep 2008
Location: Monticello
Posts: 314
Quote:
Originally Posted by Oldfrog View Post
When the wires wrapped...they shorted and a fuse blew in the main fuse box that's under the hood. There is also a shut-off relay in there, as I recall. Mine did the same thing when I hit something on the interstate. Cost me $150 to tow it home...dang it. I replaced the fuse, taped up the wires and it started. Duh !
What he said, just had this happen to me recently. The fuse for the ASD relay is probably blown. Check the small fuses in the fuse box under the hood, should be one of the 20A fuses.

98' 5.2 ltd, 4.5" lift, 33x12.50 KM2's, Clayton's longarms, 8.8/HP30 Aussie F&R
Build Thread
98BlackZJ is offline  
post #11 of 22 Old 06-25-2011, 01:59 PM Thread Starter
nickm_03
Registered User
1997 ZJ 
 
Join Date: Feb 2011
Location: Amboy
Posts: 55
We checked all the fuses. they were all fine...

1997 Jeep Grand Cherokee Laredo 4.0L I6 - Gray
nickm_03 is offline  
post #12 of 22 Old 06-25-2011, 08:32 PM
Oldfrog
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 5,092
The ones under the hood? ( not inside the vehicle) Look more closely. I'm willing to bet a nickel that one is blown. One more thing....there are some small relays in that fuse center under the hood. Swap them around. ( they are all the same). The ASD relay could be stuck.

2007 5.7 Hemi, Ltd. QD II -
1997 ZJ, 4,0 select trac, Up country, track lok.
Oldfrog is offline  
post #13 of 22 Old 06-25-2011, 08:35 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,662
Quote:
Originally Posted by Oldfrog View Post
When the wires wrapped...they shorted and a fuse blew in the main fuse box that's under the hood. There is also a shut-off relay in there, as I recall.
Blown fuse
ZeeJay1997 is offline  
post #14 of 22 Old 06-26-2011, 04:40 AM Thread Starter
nickm_03
Registered User
1997 ZJ 
 
Join Date: Feb 2011
Location: Amboy
Posts: 55
ya we checked the fuse box under the hood and swapped them..nothing was blown. im gonna start by replacing the o2 sensor then try a code reader, but since its not starting up im not getting a check engine light so im not sure if the code reader will help. but its not gettin spark from the coil, whether thats because of a bad coil or a shorted ecm, im not positive yet

1997 Jeep Grand Cherokee Laredo 4.0L I6 - Gray
nickm_03 is offline  
post #15 of 22 Old 06-26-2011, 06:17 AM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,662
Quote:
Originally Posted by nickm_03 View Post
Those would not cause it to not start though.
Did you fix the wires??????????????
ZeeJay1997 is offline  
Reply

Tags
distributor cap , fuel pump , o2 sensor , rotor , spark plugs

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Jeep Will Not Start!!! hicsurf247 ZJ Grand Cherokee Forum 13 10-02-2012 01:16 PM
94 jeep won't start!!!!!! 1994ZJ ZJ Grand Cherokee Forum 1 02-15-2011 07:11 PM
Jeep won't start. guttafixit ZJ Grand Cherokee Forum 2 02-04-2011 04:12 AM
My Jeep will not start... jj33low ZJ Grand Cherokee Forum 13 10-18-2004 06:44 AM
jeep non start celticfc ZJ Grand Cherokee Forum 4 07-03-2004 11:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome