still losing oil.???? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 06-22-2009, 06:07 PM Thread Starter
jeepjoker
Registered User
1993 ZJ 
 
Join Date: May 2009
Location: portland OR
Posts: 21
still losing oil.????

93 ZJ 4.0 limited auto 215,xxx. i recently had a shop do my leaks in my system. they did the rear main seal, and oil pan for the engine (i did my valve cover)and front and rear on trans etc.. and i'm still losing oil. . so how do i test to see if my engine is burning oil? do i do a wet compression test? or???? am i doomed for losing oil? and how do i replace the oil level sensor(not the oil pressure sensor, but the sensor in the oil pan that shows how low i am.) any suggestions?
thanks

jeepjoker is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-22-2009, 06:49 PM
sadass
Registered User
1998 ZJ 
 
Join Date: May 2008
Location: Hopeless Juction, NY
Posts: 2,499
It is not uncommon for bad valve guide seals , I had my head done on the same year 4.0 ZJ at a high milage, no more oil consumption. or at least back to a normal level of consumption. But I would due a compression test before having the head done.
As for the level sensor, check the connections before replacing. I have seen the wires pulled out on two occasions now!

fond this

5NineZJ,35mtr/k IRO 7" LA F/R Detroit F/HP-4.56 R/Aussie 44A. ARB Snorkel/JRC Sliders/ Protofab w/9500S./Bushwhackers. Novak242 TCcable.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sadass is offline  
post #3 of 5 Old 06-22-2009, 06:56 PM
sadass
Registered User
1998 ZJ 
 
Join Date: May 2008
Location: Hopeless Juction, NY
Posts: 2,499
sorry about that, try this link

http://www.justanswer.com/questions/...cherokee-4-0-l

5NineZJ,35mtr/k IRO 7" LA F/R Detroit F/HP-4.56 R/Aussie 44A. ARB Snorkel/JRC Sliders/ Protofab w/9500S./Bushwhackers. Novak242 TCcable.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sadass is offline  
post #4 of 5 Old 06-22-2009, 07:11 PM Thread Starter
jeepjoker
Registered User
1993 ZJ 
 
Join Date: May 2009
Location: portland OR
Posts: 21
i tested my compression a months a go and i got
Cylinders
1)115
2)120
3)130
4)135
5)90
6)120
(cold)
but this wasn't a wet compression test. should i do that? i also ran some sea foam in my intake but have not checked compression since. and if i had to remove my head is hard to do? also do the sensors go out allot. i have a feeling mine works good cause when its low i check the dipstick and its low. and when its not low the dipstick says its not low also. so should i even worry about that? my sensor doesn't go off all the time
jeepjoker is offline  
post #5 of 5 Old 06-22-2009, 09:17 PM
xJoshxx
Registered User
2012 WK 
 
Join Date: Sep 2008
Location: Burlington, Kentucky
Posts: 5,534
Quote:
Originally Posted by jeepjoker View Post
i tested my compression a months a go and i got
Cylinders
1)115
2)120
3)130
4)135
5)90
6)120
(cold)
but this wasn't a wet compression test. should i do that? i also ran some sea foam in my intake but have not checked compression since. and if i had to remove my head is hard to do? also do the sensors go out allot. i have a feeling mine works good cause when its low i check the dipstick and its low. and when its not low the dipstick says its not low also. so should i even worry about that? my sensor doesn't go off all the time
Cylinder Compression Pressure Range 827 - 1034 kPa (120 - 150 psi)
Maximum Variation Between Cylinders 206 kPa (30 psi)

your number 5 is running kinda low. it's 30+ below on some of the other pistons

Sold4" Hybrid lift TeraFlex coils IRO Adjustable LA's Jks tracbar 1.25spidertrax spacers 265/75/16 Dura-tracs
Quote:
Originally Posted by moPowered View Post
The SRt-8's are a liberty design.
2011 WK2 ORA2 sold
2012 WK2 SRT8 - Current
99 WJ Limited Lifted.
2001 WJ stock 4.0 304k miles
xJoshxx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
ZJ losing Idle.... zjilla ZJ Grand Cherokee Forum 14 08-05-2012 07:36 PM
Losing Oil Pressure ????? DEEPERTHEBETTER ZJ Grand Cherokee Forum 7 01-10-2009 08:25 PM
Losing power?! nddigi WK Grand Cherokee & XK Commander Forum 2 12-31-2007 08:18 AM
Losing Water kopite77 ZJ Grand Cherokee Forum 27 10-06-2007 03:19 AM
losing motivation.. MotoX5874 ZJ Grand Cherokee Forum 10 07-21-2007 11:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome