Still got Death Wobble after muchos replacements. - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Still got Death Wobble after muchos replacements.

Gear Installs at CCOR SpecialWe have Engo 10k Synthetic IN STOCK!!! Hurry while supplieIron Cross Customer JK and TJ Wrangler Bumpers now at ROCK

Reply
Unread 04-19-2013, 09:15 PM   #16
WhiteOut
Web Wheeler
 
WhiteOut's Avatar
1998 ZJ 
 
Join Date: Dec 2007
Posts: 8,177
Quote:
Originally Posted by durango-bob View Post
Bad unit bearings can also contribute to the problem. But a dry steering test (someone turning the steering wheel back and forth a bit while you look at the moving parts for slop) has always help identify items that need to be tighter.
No they can't.

WhiteOut is offline   Reply With Quote Quick reply to this message
Unread 04-19-2013, 09:16 PM   #17
WhiteOut
Web Wheeler
 
WhiteOut's Avatar
1998 ZJ 
 
Join Date: Dec 2007
Posts: 8,177
Quote:
Originally Posted by buttersjeep90 View Post
not always true about tires don't cause death wobble. i had death wobble and i took it to a few tire shops and had them look at my tires, and alignment. my passenger side tire wasn't balanced. they balanced it and death wobble went away.
It wasn't death wobble you had.
WhiteOut is offline   Reply With Quote Quick reply to this message
Unread 04-19-2013, 09:27 PM   #18
buttersjeep90
Registered User
1997 ZJ 
 
Join Date: Aug 2012
Location: Warwick, RHODE ISLAND
Posts: 135
Quote:
Originally Posted by WhiteOut View Post
It wasn't death wobble you had.
my bad, i considered it death wobble seeing as once i had gotten on the high way it shook so bad the jeep was all over my lane. anyways it fixed it. in any event if its death wobble or not its still not good and i hope he finds out whats causing it.
buttersjeep90 is offline   Reply With Quote Quick reply to this message
Unread 04-20-2013, 05:03 AM   #19
upandin1
Registered User
1997 ZJ 
 
Join Date: Feb 2013
Location: fairfield, ia
Posts: 24
Just had this problem for the 2nd time in a yrs time. Both times changed oit trac bar and was good to go
upandin1 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.