Starting problems...help! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Starting problems...help!

Artec Flash Sale - 15% off and Free Shipping over $300Rugged Ridge Bumpers, Winches, Performance from CCOR!JK Front Axle Truss

Reply
Unread 06-10-2009, 03:51 PM   #1
RLWaderacin
Registered User
1979 CJ5 
 
Join Date: Mar 2009
Location: Centerville Ar.
Posts: 203
Starting problems...help!

So I went out to the jeep and tried to start it up and nothing...no power what so ever. I figured it was the battery so we jumped it and I had to keep my foot on the gas for it to keep running. My first thought was the fuel pump-But then someone said alternator. About a week prior to my jeep not starting it would putter for a second or two right after a start. My friend said that the fuel pump was not getting enough power which in return caused the sputter. Input would be great! Thanks a lot!

RLWaderacin is offline   Reply With Quote
Unread 06-10-2009, 04:31 PM   #2
Greeeeenberg
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Suring, WI/ Houghton, MI (School-MTU)
Posts: 1,157
When you say nothing does that mean no radio lights, etc ,etc?

Always start with the battery charge it and test it. Go to like autozone or something and they will do the test for free.

Can you hear the fuel pump come in before you start it? Turn key to on postion and listen for it running
__________________
97 ZJ Orvis 5.2 108K.

Michigan Tech Jeepers Member #1
Greeeeenberg is offline   Reply With Quote
Unread 06-10-2009, 08:11 PM   #3
craddock01
Registered User
1996 ZJ 
 
Join Date: Apr 2009
Location: Ohio
Posts: 166
Check for corrosion on fuel pump relay prongs I had same problem you had drove me crazy read somewhere else about low voltage to pump from corrosion ( you can barely see the corrosion kind of dull look to it vs shiny cleaned the prongs up then stuck em in and out of the socket in the fuse box several times....bingo never a problem since.
craddock01 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.