Stalling on freeway. - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 27 Old 04-02-2013, 12:50 PM
Ruby3
Registered User
1998 ZJ 
 
Join Date: Oct 2012
Posts: 9
Sounds good. Ill have to add that to the build sheet

Ruby3 is offline  
Sponsored Links
Advertisement
 
post #17 of 27 Old 04-09-2013, 03:28 AM Thread Starter
sergio
Registered User
1995 ZJ 
 
Join Date: Apr 2012
Posts: 182
Plenum replacement gave me power but I still have that stall on the freeway. I'm stumped!
sergio is offline  
post #18 of 27 Old 04-09-2013, 10:50 AM
ilive4cars0122
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Posts: 606
Quote:
Originally Posted by sergio
Plenum replacement gave me power but I still have that stall on the freeway. I'm stumped!
Check the ignition coil yet?
ilive4cars0122 is offline  
post #19 of 27 Old 04-09-2013, 03:16 PM Thread Starter
sergio
Registered User
1995 ZJ 
 
Join Date: Apr 2012
Posts: 182
Quote:
Originally Posted by ilive4cars0122

Check the ignition coil yet?
No not yet. I was last night but isn't the ignition coil work to only turn on the jeep?
sergio is offline  
post #20 of 27 Old 04-09-2013, 07:48 PM
ilive4cars0122
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Posts: 606
Quote:
Originally Posted by sergio

No not yet. I was last night but isn't the ignition coil work to only turn on the jeep?
The ignition coil gives the spark to a wire that runs to your distributor. Then distributor then supplies that spark to each individual spark plug wire making it to the spark plugs. I think u can understand what happens next.
ilive4cars0122 is offline  
post #21 of 27 Old 05-01-2013, 12:25 AM Thread Starter
sergio
Registered User
1995 ZJ 
 
Join Date: Apr 2012
Posts: 182
So quick update. I changed the ignition coil but it made no difference at all. It still hesitates on freeway like its cutting gas. I have no idea what else to change. My last bet would be a clogged cat or fuel pump. Ehhh.
sergio is offline  
post #22 of 27 Old 05-01-2013, 04:16 AM
Rich93ZJ
Registered User
1993 ZJ 
 
Join Date: Sep 2012
Location: Richland
Posts: 461
Have you tried swapping the fuel pump relay yet. May have a flaky relay. If that doesn't do it, I would check the fuel pressure as stated in a previous post. G/L. Keep us informed.
Rich93ZJ is offline  
post #23 of 27 Old 05-03-2013, 01:28 AM Thread Starter
sergio
Registered User
1995 ZJ 
 
Join Date: Apr 2012
Posts: 182
Quote:
Originally Posted by Rich93ZJ View Post
Have you tried swapping the fuel pump relay yet. May have a flaky relay. If that doesn't do it, I would check the fuel pressure as stated in a previous post. G/L. Keep us informed.
Would you happen to know where i would be able to get a new pump relay for a good price?
sergio is offline  
post #24 of 27 Old 05-03-2013, 05:16 AM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,837
Swap it out with another relay from the PDC


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ZeeJay1997 is offline  
post #25 of 27 Old 05-04-2013, 04:43 AM Thread Starter
sergio
Registered User
1995 ZJ 
 
Join Date: Apr 2012
Posts: 182
I changed the relay. Doesn't do it as much, but its still there. Seems to go away every time I switch something out but comes back every time. I haven't done the fuel pressure check yet, but im going to try the soap and water trick. As of now im not driving it until i figure what it is. Sucks because i have my lift ready to be put in.
sergio is offline  
post #26 of 27 Old 05-05-2013, 09:12 PM
papitt
Registered User
1995 ZJ 
 
Join Date: Dec 2008
Location: Stephenville Texas 76401
Posts: 747
I bought a fuel pressure gauge set up from Harber Freight not long ago it was only about 18.00 of maybe 25.00 But cheap.
papitt is offline  
post #27 of 27 Old 06-23-2013, 06:51 PM Thread Starter
sergio
Registered User
1995 ZJ 
 
Join Date: Apr 2012
Posts: 182
So finally came to checking the fuel pressure and it's reads fine. Anymore possible ideas why? I've changed everything. Would a crankshaft do the fix?
sergio is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome