Squeaky Noise when starting engine - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Squeaky Noise when starting engine

Cess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WDGEARSHADE Pocket Tops in stock and available at ROCKRIDGE Engo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 02-10-2010, 02:12 PM   #1
OvenMits
Registered User
1997 ZJ 
 
Join Date: Nov 2009
Location: Miami
Posts: 97
Squeaky Noise when starting engine

Hey Guys.
I have a ANNOYING issue with my engine when I start it for the first time in the day. Its like a squeaky noise coming from the belt I think when the engine is cold but after I let it idle till the engine temp is normal at 240 or w.e. is normal the noises stop. I tried the stupid spray stuff, that product is BS. it actually made it worse. rofl. so yea. can anyone help me out on how to stop the squeaky noise? I already know it goes away when the engine warms up do what could this mean?

OvenMits is offline   Reply With Quote
Unread 02-10-2010, 03:10 PM   #2
OvenMits
Registered User
1997 ZJ 
 
Join Date: Nov 2009
Location: Miami
Posts: 97
anyone? cmon. someone must know a solution to this. lol
OvenMits is offline   Reply With Quote
Unread 02-10-2010, 04:47 PM   #3
OvenMits
Registered User
1997 ZJ 
 
Join Date: Nov 2009
Location: Miami
Posts: 97
lol is my question that bad? =/
OvenMits is offline   Reply With Quote
Unread 02-15-2010, 06:01 PM   #4
jmadams6
Registered User
2000 TJ Wrangler 
 
Join Date: Feb 2010
Location: St. Petersburg
Posts: 1
that same thing happened to my jeep a couple months ago
just took it to the shop and had the belts replaced. solved everything
jmadams6 is offline   Reply With Quote
Unread 02-15-2010, 07:22 PM   #5
harm63
Registered User
1994 ZJ 
 
Join Date: Dec 2009
Location: Missouri
Posts: 7
I had that issue about 1 month ago. 1 - you need to replace your belt. 2 - Make sure that you have it tight enough on the tension adjuster bolt. It took multiple adjustments on my part to get it tight enough that the squeaking went away. Runs like a champ now.
__________________
"A good pilot is compelled to always evaluate what's happened...so he can apply what he's learned." - Top Gun
harm63 is offline   Reply With Quote
Unread 02-15-2010, 08:03 PM   #6
JesseOR
Registered User
1993 ZJ 
 
Join Date: Oct 2009
Location: Eugene, Oregon
Posts: 1,621
Replace the belt. Pretty self explanatory.
__________________
-Jesse-
GO DUCKS!

www.facebook.com/jesse.whitehargrove
JesseOR is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.