speedometer cluster is dead - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > speedometer cluster is dead

RIGID LED Light Blowout Sale - All Sizes, All Series, all ECGS Black Friday Sale!!6th Annual, Beat Your Wife to the Credit Card Sale!

Reply
Unread 03-23-2013, 12:44 PM   #1
islangink
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: king george, VA
Posts: 11
speedometer cluster is dead

I had installed an aftermarket stereo system in my 98 zj n after a couple weeks when i hit a bump or the bass hit really hard my radio would flicker out. I was thinking loose wire so I pulled the radio out n sure enuff the power wire was loose. in the process of pulling the radio out the bare power wire touched the metal bracket n sparked. I fixed the radio issue but then I noticed about a mile down the road hat my cluster wasnt working at all, no speedo,tach,fuel,batt,oil odometer,lights NOTHING. I did the test where u hold in the trip button n turn the key on n only the abs light comes on. Turn signal lights work but no other notifications or dummy lights come on except abs. I went out n bought a used cluster n installed it but it doesnt do anything but the abs light stays on on this one. I also checked the fuse inside the jeep all the way towards the front middle row n its fine. Any advice that could be given would be greatly appreciated.

islangink is offline   Reply With Quote Quick reply to this message
Unread 03-23-2013, 08:26 PM   #2
RTLee
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: St. Joseph, Michigan
Posts: 17
Are all fuses checking ok?
RTLee is offline   Reply With Quote Quick reply to this message
Unread 03-23-2013, 08:37 PM   #3
SuperStew11
Registered User
2000 WJ 
 
Join Date: Mar 2013
Posts: 194
Chances are when you sparked the wire you popped a fuse, same thing was happening in my old Dakota, new radio and a bare was near a metal bracket, hit a bump and my most of my cluster would go out, went through numerous fuses and a year of driving with it pulled the radio out one day and found the bare wire
SuperStew11 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.