speedo issues help please - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 04-11-2011, 07:39 PM Thread Starter
camojeep95
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: port royal
Posts: 3
speedo issues help please

My 95 zj I replaced the speed sensor in the tranny and still don't work once it get 2 10 mph from higher it just shuts off and throws my check engine light on and it stays at 0 sometimes it will come on when it shifts sometimes it don't and when its not working it won't shift into tthe last gear....and another thing I have a bad static noise coming from drive side tweeter amd door speaker loose wire maybe? And advise on my issues?

camojeep95 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-11-2011, 11:17 PM
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman
Posts: 2,346
Vehicle speed sensor is on the back of transfer case for 4x4's and extension housing (behind o/d unit) on 2wd's.

Loose or broken wire is possible, the tweeter wiring is spliced into the LF speaker wiring behind the dash, could possibly be the radio or amp I guess.
jnicewan is offline  
post #3 of 4 Old 04-12-2011, 07:54 AM Thread Starter
camojeep95
Registered User
1995 ZJ 
 
Join Date: Jan 2011
Location: port royal
Posts: 3
I already replaced the speed sensor I'm point to try the ones in the wheels next and the spear I tried balancing to the d
Pass side and it still does it in the driver side
camojeep95 is offline  
post #4 of 4 Old 04-14-2011, 08:57 AM
droopydawg
Registered User
1999 XJ Cherokee 
 
Join Date: May 2009
Location: Lake Forest, Illinois, USA
Posts: 64
I had a similar issue. I even thought it was the speed sensor too, and replaced it. Turned out, it was one soldiered connection inside the speedo itself that had worked itself loose. I took out the speedo unit (took about an hour) and took it to a speedo specialist and he had it working in about 30 minutes. $100.
droopydawg is offline  
Reply

Tags
zj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
High RPM issues and tranny issues Jeep Kid ZJ Grand Cherokee Forum 3 01-26-2010 04:09 PM
04 GC hvac issues-blower motor and other issues nation1979 ZJ Grand Cherokee Forum 1 09-02-2009 09:47 PM
++FIXED++ overdrive and speedo issues! mattready ZJ Grand Cherokee Forum 0 02-19-2009 08:09 PM
Speedo off by 10% cw8 ZJ Grand Cherokee Forum 8 09-11-2007 06:28 AM
Speedo help Decipticon ZJ Grand Cherokee Forum 4 05-04-2005 11:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome