JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   Spark plug picks (http://www.jeepforum.com/forum/f13/spark-plug-picks-1599889/)

davidtownsend 09-18-2013 04:10 PM

Spark plug picks
 
2 Attachment(s)
Attachment 688537Attachment 688545

This is my odd cylinders. From right to left. What does the greenish color mean? My even cylinders are like that too. Thanks in advance.

dusterdude 09-18-2013 04:26 PM

Have you use any fuel additives?

Jeeples 09-18-2013 04:34 PM

It's probably the cheesy chrome plating that E3 uses on their ground straps burning off.

zjosh93 09-18-2013 04:36 PM

^^^ Both of these were my first thoughts.

davidtownsend 09-18-2013 04:50 PM

I don't use any additives. And they have been in there a long time. Almost 2 years.

JeepNicholson 09-18-2013 05:53 PM

They're heavily oxidized. It's not too uncommon.
Next time though I'd switch out those E3s for copper plugs.

pageman 09-18-2013 06:05 PM

i always use platinum denso plugs they cost 2.25 each at adcanced but they are pre gapped at .40 when the v8 calls for .35

also i have hated the e3 since the start they work horribly on my race bikes and every turbo car i had they dident do well

JeepNicholson 09-18-2013 06:15 PM

Quote:

Originally Posted by pageman (Post 16123121)
i always use platinum denso plugs they cost 2.25 each at adcanced but they are pre gapped at .40 when the v8 calls for .35

also i have hated the e3 since the start they work horribly on my race bikes and every turbo car i had they dident do well

Should that be .035?

pageman 09-18-2013 06:19 PM

(it says catalyst info and is black whit white lettering)yes in the shop manual and the placard on the radiator frame says plugs need to run at 0.035

yah sorry about that pressed the zero and it dident click lol

davidtownsend 09-18-2013 06:48 PM

Those e3 did goods to me but I swapped then out with autolight platinums. I have 8mm wires and my msd ignition is in the mail.

jabba974 09-18-2013 08:40 PM

Looks a little lean to me... How many miles on them?

davidtownsend 09-18-2013 08:55 PM

Quote:

Originally Posted by jabba974 (Post 16128353)
Looks a little lean to me... How many miles on them?

Probably 15. I put them in about two years ago.


The time now is 12:50 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.