Some transmission problems and then some - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Some transmission problems and then some

ARTEC JK UNDER ARMOR - 4 door Bellypan KitsPoison Spyder DeFender Inner Fender KitsCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 03-31-2004, 11:45 AM   #16
BOOM
Registered User
 
Join Date: Mar 2004
Posts: 12
OK guys, Sorry i took so long to respond. I went ahead and worked on my car this weekend. I changed the fluid and filter. I also checked my tps and it seems fine. I adjusted the bands ( the one by the filter ) and i tried to adjust the bands on the outside one. The socket I need to adjust the bands are square. I used a 1/4 inch hex socket on the inside one and it seemed to work fine to torque with, but the outer one I need to find a 3/8 square socket or something comparable. I don't know what they're called and I checked all over town for one yesterday. I tried to find a 8 point socket, but only found 12 point and they would not fit. Does anyone know what this particular socket is called or where i could find one, or somehow of doing the torque without it ? ? ? Other than that everything seems to be running smoother and I haven't been experiencing slippage I'm still having a slight issue with my idle being a bit low when i pull up to a stop. It will sometimes jerk a little bit like a gas cutoff or something. And I'm still having some vibrations when accelerating and when cruising along in overdrive. Well that's all for now. Hope you guys can help. Boy am I a project

Thanks

BOOM

__________________
94' Grand Cherokee Laredo
i6 4.0 Liter 4 X 2

Last edited by BOOM; 03-31-2004 at 02:06 PM..
BOOM is offline   Reply With Quote
Unread 04-02-2004, 10:57 PM   #17
BOOM
Registered User
 
Join Date: Mar 2004
Posts: 12
I guess my next option is to go ahead and check out my bearings. I hate having to go through this again. I went to change em out on my first engine and some *** left my engine open for six months letting it rust. But if i gotta i will. So we'll see how this weekend goes with that

BOOM
__________________
94' Grand Cherokee Laredo
i6 4.0 Liter 4 X 2
BOOM is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.