Some transmission problems and then some - Page 2 -

LinkBack Thread Tools
post #16 of 17 Old 03-31-2004, 11:45 AM Thread Starter
Registered User
Join Date: Mar 2004
Posts: 12
OK guys, Sorry i took so long to respond. I went ahead and worked on my car this weekend. I changed the fluid and filter. I also checked my tps and it seems fine. I adjusted the bands ( the one by the filter ) and i tried to adjust the bands on the outside one. The socket I need to adjust the bands are square. I used a 1/4 inch hex socket on the inside one and it seemed to work fine to torque with, but the outer one I need to find a 3/8 square socket or something comparable. I don't know what they're called and I checked all over town for one yesterday. I tried to find a 8 point socket, but only found 12 point and they would not fit. Does anyone know what this particular socket is called or where i could find one, or somehow of doing the torque without it ? ? ? Other than that everything seems to be running smoother and I haven't been experiencing slippage I'm still having a slight issue with my idle being a bit low when i pull up to a stop. It will sometimes jerk a little bit like a gas cutoff or something. And I'm still having some vibrations when accelerating and when cruising along in overdrive. Well that's all for now. Hope you guys can help. Boy am I a project



94' Grand Cherokee Laredo
i6 4.0 Liter 4 X 2

Last edited by BOOM; 03-31-2004 at 02:06 PM.
BOOM is offline  
Sponsored Links
post #17 of 17 Old 04-02-2004, 10:57 PM Thread Starter
Registered User
Join Date: Mar 2004
Posts: 12
I guess my next option is to go ahead and check out my bearings. I hate having to go through this again. I went to change em out on my first engine and some *** left my engine open for six months letting it rust. But if i gotta i will. So we'll see how this weekend goes with that


94' Grand Cherokee Laredo
i6 4.0 Liter 4 X 2
BOOM is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
transmission problems dex1 ZJ Grand Cherokee Forum 1 11-29-2008 07:47 PM
Transmission problems. HELP! jmack549 WK Grand Cherokee & XK Commander Forum 9 10-30-2008 11:01 PM
'98 transmission problems gbt102 ZJ Grand Cherokee Forum 4 08-24-2006 08:11 PM
Transmission problems (TCU or TCM) remicman WJ Grand Cherokee Forum 4 06-03-2004 08:31 PM
Transmission Problems JeepGuyRyan ZJ Grand Cherokee Forum 5 08-09-2002 07:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome