Smell gas in my oil - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Smell gas in my oil

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsWant to be able to SEE? DOT Approved Headlights for under

Reply
Unread 11-23-2011, 08:24 AM   #16
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport, Ohio
Posts: 257
How old is your O2 sensor? Before I changed mine out, I noticed some "black" smoke at idle after a minute or so, and really seen some when I got on it. My oil also had the gas smell in it until I changed the O2 sensor. Just a thought since nothing is being thrown in your kettle.

__________________
'94 Limited ZJ (CRUSHED, kept the 5.2L, 46RH & 249 TC)
'96 Orvis ZJ
'98 Slate 5.9 ZJ (DD)
rlcii77 is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 09:48 AM   #17
somebody5788
Registered User
1994 ZJ 
 
Join Date: Aug 2008
Location: Warsaw, Indiana
Posts: 1,031
With 3000 miles on the oil gas smell is very common. It's honestly rather rare that we do an oil change at the shop and there isn't a little gas smell. If you live in town and do a lot of short trips it is going to happen even if the car is brand new. Now if it's got a distinct gas odor after like 1500 miles that's a problem.

The reason for the short trips thing is because if the engine and oil don't get up to full operational temp everytime you drive it then there is no time to burn off or evaporate any of the gas that gets into the oil. Under optimal conditions the gas evaporates and goes through the PCV to the intake and burns off.
__________________
2006 Honda 919 - Summer Daily
1994 Jeep ZJ - RC Long Arms | RE 4.5" springs | Bilstein 5100's | RE SS brake lines | Falken 31x10.5-15 tires | Flatland 4x4 bumpers | Summit Soft 8's 15x8 3.75 BS wheels
somebody5788 is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 10:35 AM   #18
wsar10
Registered User
2003 WJ 
 
Join Date: Dec 2008
Location: State College, PA, PA
Posts: 2,150
Quote:
Originally Posted by somebody5788 View Post
With 3000 miles on the oil gas smell is very common. It's honestly rather rare that we do an oil change at the shop and there isn't a little gas smell. If you live in town and do a lot of short trips it is going to happen even if the car is brand new. Now if it's got a distinct gas odor after like 1500 miles that's a problem.

The reason for the short trips thing is because if the engine and oil don't get up to full operational temp everytime you drive it then there is no time to burn off or evaporate any of the gas that gets into the oil. Under optimal conditions the gas evaporates and goes through the PCV to the intake and burns off.
^this is very true, you can always tell on a UOA when somebody does alot of short trips becuase they have high fuel dilution. Also long idling will cause this.
__________________
QUOTE=billzcat1;wsar10 is right on point on this oil thread - as usual. Anyone reading this would be well-served taking his advice.


-03 WJ laredo 4.0 120k a few minor mods
-93 XJ 5spd, 3" zone lift
wsar10 is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 10:52 AM   #19
badbird17x
Web Wheeler
 
badbird17x's Avatar
1994 ZJ 
 
Join Date: Jul 2011
Location: lisbon, nd
Posts: 3,988
My 5.2 was loosing op, and gaining oil. I replaced all the injectors to fix it. I'm not gonna say this is for sure your problem. Mine also would act hydro locked after letting it sit a bit, so I knew it was injectors. You could have an o2 issue. I put 32lb injectors in a car needing 26lb once, it's oil stunk of gas in 30 miles, so the computer may be throwing to much fuel at it.
__________________
94 jz, bruiser, la, cage,5.3 ls, 36 swampers 98 jz, the mutt, 3.5 iro, 33 swampers, avalanche conversion, 02 north face avalanche blacked out work truck, 06 rhino R1 engine, 4x4, Leeroy's custom paint, 04 escalade wifes truck 22s, 03 duramax 18s, completely blacked out, efilive by nick, wicked wicked truck, 39 chop chevy rod, aluminum 5.3 ls, 08 apex, 310hp mcx turbo, holz 162, completely black, CCM built.
badbird17x is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 11:52 AM   #20
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, Italy
Posts: 16,496
Do you smell it on the dip stick or in the crank case?
PolkaPower is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 12:17 PM   #21
speedbucket
Registered User
1993 ZJ 
 
Join Date: Jan 2011
Location: chesapeake, VA
Posts: 3,562
Dipstick. I'm in Kentucky right now for Turkey day. Just seemed thin when I checked level. So I smelled and smelled of fuel. Those injectors are original equipment
__________________
http://www.jeepforum.com/forum/f22/speedbuckets-zj-build-1361322/
V8 zj at 6" . Double tri rear and true 3 link front. Stretched to 108"
speedbucket is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 12:29 PM   #22
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, Italy
Posts: 16,496
My crank case smells a little like gas vapors but if you smell it on the dip stick then it's possibly a stuck open or leaky injector. Is the oil level higher than usual?
PolkaPower is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 12:54 PM   #23
wsar10
Registered User
2003 WJ 
 
Join Date: Dec 2008
Location: State College, PA, PA
Posts: 2,150
either way I would get that oil out of there asap, even if you replace it with just cheap dino it's better than tampered with viscosity and TBN.
__________________
QUOTE=billzcat1;wsar10 is right on point on this oil thread - as usual. Anyone reading this would be well-served taking his advice.


-03 WJ laredo 4.0 120k a few minor mods
-93 XJ 5spd, 3" zone lift
wsar10 is offline   Reply With Quote Quick reply to this message
Unread 11-23-2011, 01:49 PM   #24
speedbucket
Registered User
1993 ZJ 
 
Join Date: Jan 2011
Location: chesapeake, VA
Posts: 3,562
I have a bad Plenum gasket and she Burns half quart every 800-1000 miles
__________________
http://www.jeepforum.com/forum/f22/speedbuckets-zj-build-1361322/
V8 zj at 6" . Double tri rear and true 3 link front. Stretched to 108"
speedbucket is offline   Reply With Quote Quick reply to this message
Reply

Tags
gas , oil

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.