Sloppy Suspension - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 03-18-2014, 06:22 PM Thread Starter
ALECR1231
Registered User
1997 ZJ 
 
Join Date: Mar 2014
Location: Novi
Posts: 4
Sloppy Suspension

I got this ZJ a couple months back knowing it needed some work. Its my daily driver and the past week the steering and suspension have been extremely sloppy.If i'm driving down the road and it wonders all over the place. When pulling into a parking spot at slow speeds the front feels like its shimming and lunging. I put a new steering gear box with new pump and a new track bar. I just checked the ball joints, HUB's, and tie rod ends. I'm at a lost I have know idea what it could be. Any input would be greatly appreciated.

ALECR1231 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 03-18-2014, 06:28 PM
mrgimble
Registered User
2015 JK Wrangler 
 
Join Date: Aug 2007
Location: Halifax, Nova Scotia, Canada
Posts: 438
Check the control arm bushings.
mrgimble is offline  
post #3 of 7 Old 03-18-2014, 06:47 PM
rstantoniii
Registered User
1998 XJ Cherokee 
 
Join Date: Feb 2014
Location: Mount Pleasant
Posts: 221
I had a similar problem. It was the drivers side inner tie rod end for me (the one that attaches to the pitman arm). Swapped them out and I was good to go.
rstantoniii is offline  
post #4 of 7 Old 03-19-2014, 05:48 AM Thread Starter
ALECR1231
Registered User
1997 ZJ 
 
Join Date: Mar 2014
Location: Novi
Posts: 4
I dont think it could be the control arm bushings, a new set came with the lift.
I'll check out the tie rod ends, I just got an alignment, im surprised that they didnt say anything about the tie rods being worn.
I'll let you know what I find out.
ALECR1231 is offline  
post #5 of 7 Old 03-19-2014, 05:54 AM
Skydmark1
Registered User
1998 ZJ 
 
Join Date: Apr 2007
Location: Northern
Posts: 438
Sway bar end links and lower control arm bushings are both pretty popular things to wear and give you that feeling you are describing. I've got the same thing going on, putting new end links in this weekend to see if that helps.

-2013 JKU Sport, bone stock, Auto with 3.73's
-1998 ZJ Laredo, 4.0 42RE Selec-Track, 30" M/T tires
Skydmark1 is offline  
post #6 of 7 Old 03-19-2014, 05:59 AM Thread Starter
ALECR1231
Registered User
1997 ZJ 
 
Join Date: Mar 2014
Location: Novi
Posts: 4
Let me know how it turns out.
ALECR1231 is offline  
post #7 of 7 Old 03-19-2014, 08:35 AM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,370
Quote:
Originally Posted by mrgimble View Post
Check the control arm bushings.
X 2 on this. Replace all control arms with new bushings starting with the lowers.
PolkaPower is offline  
Reply

Tags
suspension , zj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome