Singed/Burning smell coming from 5.9 ZJ.. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Singed/Burning smell coming from 5.9 ZJ..

Building a Bumper?Ruffstuff Axle Simple Swap Kit!~Artec JK 1 TON SWAP~

Reply
Unread 11-14-2013, 02:10 AM   #1
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Singed/Burning smell coming from 5.9 ZJ..

Hey guys... tonight when I was leaving my Girlfriends house and heading back home I noticed a burning smell coming from my air vents.. Smelt like a house was on fire... I thought it was just from outside... It happened right when my thermostat opened up though. I can see the steam coming from my radiator every winter when the thermostat opens..

I didn't think anything of it and when I got home and got out I smelt the same burning smell, so I opened my hood and its deff coming from the engine somewhere... The smell isn't a smell from burning oil or anything of the sort.. It literally smells like something was on fire. I got my bright flashlight out and looked all over and I don't see anything melted or singed... The smell is coming from the drivers side. I felt the bottom of the heater hose that goes from the waterpump to the heatercore and the bottom of it felt a little melted.... I know it sits right above the exhaust manifold but still...

Im not sure if this is where I was smelling it because when I smelt my hand after rubbing it on the hose it didn't smell burned... So im wondering if its something else.. The smell seems strongest behind the airbox and in front of the brake reservoir and between those 2 items and the heater hose.... because as I said it happened right as my thermostat opened... Kinda freakin me out so I took the fire extinguisher out of the 4.0 and put it in the 5.9... Im not taking any chance next time..

Any ideas though ? As I said the smell.. smelt like burning house.. like wood on fire.. or leaves on fire... didn't smell like burning rubber, or oil or anything like that. And the smell is deff lingering on the drivers side. I don't smell it on the passenger side

__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 11-14-2013, 10:03 AM   #2
Snowfan2
Registered User
1998 ZJ 
 
Join Date: Jan 2012
Location: North of Amarillo, Tx
Posts: 506
Same smell here on my 9er. Very slight. Have no idea what or where.
Snowfan2 is offline   Reply With Quote
Unread 11-14-2013, 02:01 PM   #3
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Do you know the smell of burning electric components/wiring? Could be something like that. The only way to really pinpoint it is to let it idle while you poke around under there.

Check the spark plug wires, heater hoses, any sensors/wiring harnesses near the manifold, evap lines that go parallel/behind the motor and that cheap plastic crap that wraps around certain wires.
JasonStebbins is offline   Reply With Quote
Unread 11-14-2013, 02:34 PM   #4
Snowfan2
Registered User
1998 ZJ 
 
Join Date: Jan 2012
Location: North of Amarillo, Tx
Posts: 506
Smells more like a campfire than anything electrical.
Snowfan2 is offline   Reply With Quote
Unread 11-14-2013, 03:46 PM   #5
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Yea exactly... smells like someone is burning wood at a campfire.. Its very strange.. It doesn't smell electrical... I have smelt burned electronics from working on computers and it didn't smell like that.. It literally smells like a ashy fireplace lol. I once had that cheap plastic tubing wrapped around my wires near the manifold and it melted them because of that but it didn't quite smell like that... Im gonna go back out and look again, but last night I didn't see anything that's not by the manifold. The heaterhose of course is above manifold but its mounted like that.. Then of course spark plug wires are obviously near it but they are fine... I don't see any other electrical wires near it

But I'll let it run idle like suggested and watch it to see if I can find where its coming from. If it does it again.. Im not sure.. maybe it was leaves burning or something ?? Who knows... but it has me worried my engine is going to catch fire all of a sudden
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 11-14-2013, 03:47 PM   #6
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 5,380
Could be some leaves got into the fan motor...wild guess
HighLonesome is offline   Reply With Quote
Unread 11-14-2013, 03:51 PM   #7
StPaul59
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: St Paul, MN
Posts: 304
It is that time of the year.. A leaf for sure. No worries.
StPaul59 is offline   Reply With Quote
Unread 11-14-2013, 04:24 PM   #8
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Quote:
Originally Posted by HighLonesome View Post
Could be some leaves got into the fan motor...wild guess
Good point, especially since he said he smelled it through the vents.

Pull the blower and check it out, only takes a few minutes.
JasonStebbins is offline   Reply With Quote
Unread 11-14-2013, 05:14 PM   #9
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
I found it.. I was under the Jeep just now and on top looking and I found a singed white mark on that steering wheel pole thing that connects to the steering rack.. next to the exhaust manifold.. I wiped it with my hand and sure enough smelled like burned ash.. I also had a few leaves right by it. I removed them all... then proceeded to just check out the rest of the Jeep underneath...

Uhg seems like my steering rack might be leaking.... and I also found my rubber transmission line going from the hard line to the aux cooler is cracked from end to end on the side.. So that needs to be replaced before it springs a leak and I burn up my transmission... Maybe this was a blessing in disguise to show me that hose needed replacing.

Does it look like the steering rack is leaking to you ? It looks like the fluid is coming from where the pitman arm connects to the rack... I have fluid all over the nut and my sway bar ect... My power steering pump seems to be leaking for the 200th time again too, but when that leaks it only leaks on a ball joint and then drips on the pavement the steering rack isn't directly under the pump so I think I have 2 separate leaks... Im wondering if the steering rack is leaking because of me being run off the road over a median because of this young chick in her van turning into my lane about a month ago.. Im also noticing a poping sound when I back up and turn my wheel...

Oh and I noticed my BRAND new lower control arms the rubber is tearing and cracking.... wtf... cheap *** junk..

__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 11-14-2013, 06:07 PM   #10
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,745
It may be leaking a little but it doesn't look bad. Hard to tell from the pic. Did the fluid level drop a lot? Check the lines where they bolt into the steering gear. Sometimes it leaks from there and drips down. That absolutely would not have come from you running up on a median, if they leaked that easily then mine would have gushed out a year ago from off roading. These things are old and they eventually wear out. I replaced my steering gear several months ago.

The pop could be any number of things but it's usually the track bar.

What brand control arms did you get? I got Moog and they seem to be holding up nicely so far.
PolkaPower is offline   Reply With Quote
Unread 11-14-2013, 08:25 PM   #11
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Im not sure I just went to advance auto and got 2 brand new control arms.. Its been like 8 months now and they are starting to look like my original ones.. the rubber is tearing.. It isn't leaking too bad I don't see drips on the pavement just my sway bar is coverd in it and the little windshield plastic thing under the swaybar is oily too... I only had to fill it up with like a very tiny amount to get back to the C line
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 11-15-2013, 04:47 AM   #12
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
well turns out it wasn't leaves.. Its still burning and smelling singed... My mom and girlfriend could smell it as well.... It only starts to smell burned once the Jeep reaches 200f.. Same spot drivers side... Nothing is even near the manifold....

What is that black cylinder like thing between the air box and brake reservoir ? it has a bunch of wires coming out of it... it almost smells like its coming from that... I wish I could find out where this coming from before a fire starts or something burns and causes major dmg
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote
Unread 11-15-2013, 10:44 AM   #13
xcaliber81
Registered User
1994 ZJ 
 
Join Date: Jul 2012
Location: Prince George, B.C
Posts: 2,743
maybe post up a pic.
__________________
Im indian my elders name is Jeep Grand Cherokee, I mean Chief Grand Cherokee. Quoted from Peter Griffin.
xcaliber81 is offline   Reply With Quote
Unread 11-15-2013, 10:56 AM   #14
Pierre_r
Senior Member
 
Pierre_r's Avatar
1989 XJ Cherokee 
 
Join Date: Jul 2009
Location: Sweden
Posts: 525
I think i know what you mean and its a purge solenoid for the emission system.

If it i that solenoid that "smells like its on fire" it,s bad because its conected to the fueltank.
And fire + gas = no more jeep.
Pierre_r is offline   Reply With Quote
Unread 11-15-2013, 11:17 AM   #15
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 3,780
Ill take a picture and circle where the smell is coming from... gimme a second. It isn't the purge solenoid I checked that earlier






Ok here, this whole area on the pic is where I can smell it.. What is that black thing in the middle ? the round cylinder thing... Btw I might have found the problem... again it could be leaves. I went under the Jeep noticed the heatsheild in the back (bottom) on my manifold was bent up touching the exhaust manifold making a U shape. I bent it down and a couple leaves fell out and they were gray and brittle smelt like ash. I guess those leaves were cooking sitting up against the manifold directly like that.

edit: Ran the Jeep up to temp I don't smell ash anymore.. I hope those leaves that were in the heatsheild against the manifold was the problem.. Only thing I smell now is burning antifreeze. The thermostat housing I didn't seal properly when I put my intake back together when I did my plenum and its been leaking slightly ever since but not enough for me to want to take it apart and redo it... IDC about the burning coolant... just didn't like the burning ash smell lol...
__________________
2013 6.2 V8 Camaro SS 4k miles
1998 5.9 V8 ZJ 160k miles
1998 4.0 I6 Laredo ZJ 210k miles
Candymancan is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.