Service 4x4 switch? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Service 4x4 switch?

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 05-06-2011, 08:50 PM   #1
Canyon411
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: Spokane, Wa (Up In The Evergreen)
Posts: 667
Service 4x4 switch?

Picked up a second 95zj limited last weekend (couldn't have just one) and it has the typical issues my first one did. Warped front rotors (replaced with-in 24 hours of owning it), yellowed opaque headlamps (replaced headlamps, corners and turn on both sides), various but small issues like windows that dont work, doors that wont unlock and the like.

The vic (atleast this one works) indicates rear lamp failure (which is bs but I am sure it is solder joint issues and I will tackle that later) and it's latest warning is to service 4 wheel drive switch. Is it refering to my v/c (which I know is shot) or is there a switch that needs to be replaced? If so, what does it do and where is it?

Canyon411 is offline   Reply With Quote
Unread 05-07-2011, 12:32 AM   #2
vonericsen
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: Longmont, Colorado
Posts: 774
Mine would flash that warning all the time so I just disconnected the wire behind the vic.
That warning only refers to the sensor that will tell you which 4wd mode you are in on the vic.

Sent from my DROIDX using JeepForum
__________________
[URL="http://www.jeepforum.com/forum/f197/vonericsens-build-thread-995145/"]Build Thread[/URL]

Moss Green 95 5.2l zj- 3in lift (2" BB + Upcountry coils), 255 75 R17 BFG M/T on JK Moabs, Durango Airhat, Mopar ECU, Mopar Tire Carrier
vonericsen is offline   Reply With Quote
Unread 05-07-2011, 11:23 AM   #3
gomes512
Registered User
1994 ZJ 
 
Join Date: Nov 2005
Location: Des Plaines, IL
Posts: 1,142
The rear lamp failure isn't a loose connection issue but a bulb issue. Use a bulb different from what is spec'd in the manual and you'll get the warning. Has to do with the resistance it detects.

Took me a while to figure that one out.
gomes512 is offline   Reply With Quote
Unread 05-07-2011, 11:44 PM   #4
Canyon411
Registered User
1995 ZJ 
 
Join Date: Oct 2010
Location: Spokane, Wa (Up In The Evergreen)
Posts: 667
Ah, now that is worth following up on!! I have pulled/checked/cleaned and/or replaced just about every light bulb the ole girl has in her but I never thought about making sure the bulbs had factory correct part numbers. Thanks for the heads up .... Well, maybe not cause now I will have to re-pull every bulb and check for numbers. Oh well, I guess trouble shooting is (I hesitate to say the word fun) a little less frustrating when it's a new member to my zj family.
Canyon411 is offline   Reply With Quote
Unread 12-15-2011, 11:12 AM   #5
edpmedic
Registered User
1995 ZJ 
 
Join Date: Nov 2011
Location: Baldwin, NY Long Island
Posts: 1,050
I'm getting the same thing with the switch and my rear lights. But my bulbs are correct and they are all working including the ones on the back window. It has been working fine till today. So does that make it the VIC unit cause I have to keep setting the time and date every couple of days.

Also I finally filled it all the way with gas and my guage goes to empty instead of full.
__________________
Never4get those who gave their lives on 09-11-01 WTC and Pentagon. FDNY-EMS-NYPD-PAPD. Also those who are still dying.
_______________________________________________
"Freedom is never voluntarily given by the oppressor; it must be demanded by the oppressed."
Martin Luther King, Jr.
_______________________________________________
"Always aim at complete harmony of thought and word and deed. Always aim at purifying your thoughts and everything will be well."
Mahatma Gandhi
_______________________________________________
Feel the Sunshine on your face
edpmedic is offline   Reply With Quote
Unread 06-25-2013, 08:16 AM   #6
wcf59
Registered User
1998 ZJ 
 
Join Date: Mar 2010
Location: St Louis,MO, IL
Posts: 43
Make sure you check the bulbs in the rear sidemarkers. They trip the light sensor too.
wcf59 is offline   Reply With Quote
Unread 06-25-2013, 11:35 AM   #7
Jonboy2312
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Montreal, QC
Posts: 40
As far as the "SERVICE 4WD SWITCH" goes, check if it goes away if you apply a bit of pressure on the VIC itself (as in, just pressing your finger against the screen). If the warning goes away and all four wheels light up on the diagram, there's nothing wrong with the switch. It's just poor contact in the back of the VIC, either cracks in soldering for the socket or maybe just oxidation in the connector.
Jonboy2312 is offline   Reply With Quote
Unread 06-25-2013, 04:26 PM   #8
tucsonzj
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 2,114
my vic did the service 4wd, pressed lower center, went away. I opted for the 2wd cubby instead of the vic (best mod to date) and just yanked the stupid thing out. Turned out it wasn't fully clipped together when I pulled it out, compressed it so it clicked back together, and no more beep beep. But I still like the cubby. I cracked the screen hitting the thing one time, so if you want my VIC for parts or wires let me know lol.
__________________
"washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder."
tucsonzj is offline   Reply With Quote
Unread 06-25-2013, 06:19 PM   #9
leftfield6
Where are my damn keys?
 
leftfield6's Avatar
1964  
 
Join Date: Oct 2005
Location: Beautiful South
Posts: 256
Can someone point me to a pic of this cubby?
__________________
(Current) 98 Grand Cherokee Limited 5.9
http://www.fuelly.com/driver/leftfield6/grand-cherokee

(former) 98 Grand Cherokee Laredo
77 CJ-5
75 CJ-5
leftfield6 is offline   Reply With Quote
Unread 06-25-2013, 08:49 PM   #10
jeeepguy
Registered User
1998 ZJ 
 
Join Date: Aug 2005
Location: Earth
Posts: 2,491
Quote:
Originally Posted by leftfield6 View Post
Can someone point me to a pic of this cubby?
ZJ dash cubby
__________________
"Si Vis Pacem Para Bellum"

"Great danger lies in the notion that we can reason with evil"
Doug Patton
Quote:
...We use words like honor, code, loyalty. We use these words as the backbone of a life spent defending something. ...I have neither the time nor the inclination to explain myself to a man who rises and sleeps under the blanket of the very freedom that I provide, then questions the manner in which I provide it. I would rather you just said thank you, and went on your way, Otherwise, I suggest you pick up a weapon, and stand a post...
Quote:
I bought the HI-WAY BLASTER HORN that's 139dB and every time I honk the horn an Angel dies.
Quote:
Revelation 13:16-18
16 - He causes all, both small and great, rich and poor, free and slave, to receive a mark on their right hand or on their foreheads,
17 - and that no one may buy or sell except one who has the mark or the name of the beast, or the number of his name.
18 - Here is wisdom. Let him who has understanding calculate the number of the beast, for it is the number of a man: (Real ID and RFID chips)
Think about it...
jeeepguy is offline   Reply With Quote
Unread 06-25-2013, 08:55 PM   #11
leftfield6
Where are my damn keys?
 
leftfield6's Avatar
1964  
 
Join Date: Oct 2005
Location: Beautiful South
Posts: 256
Quote:
Originally Posted by jeeepguy View Post
A Google images search link? Is that supposed to be helpful? That search brings up a gazillion images, only ONE of which shows a half-assed picture showing part of the cubby others have referred to above.

Not helpful.

Oh, well, no biggie. My VIC is good for telling me my coolant sensor is bad.
__________________
(Current) 98 Grand Cherokee Limited 5.9
http://www.fuelly.com/driver/leftfield6/grand-cherokee

(former) 98 Grand Cherokee Laredo
77 CJ-5
75 CJ-5
leftfield6 is offline   Reply With Quote
Unread 06-25-2013, 09:17 PM   #12
tucsonzj
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 2,114
Quote:
Originally Posted by leftfield6 View Post
A Google images search link? Is that supposed to be helpful? That search brings up a gazillion images, only ONE of which shows a half-assed picture showing part of the cubby others have referred to above.

Not helpful.

Oh, well, no biggie. My VIC is good for telling me my coolant sensor is bad.
one in my build thread. apparently jf is still doing the photo switch so you can't see it anyways.
__________________
"washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder."
tucsonzj is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.