Service 4wd switch ? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Service 4wd switch ?

RIGID LED Light Blowout Sale - All Sizes, All Series, all Ruffstuff Axle Simple Swap Kit!Ruffstuff's Monster Shock Brackets!

Reply
Unread 06-14-2013, 07:55 PM   #1
a70eliminator
Registered User
 
Join Date: Dec 2004
Location: Kent Ohio
Posts: 864
Service 4wd switch ?

I'm getting this message on my vic so I pulled the switch out of the transfer case and checked continuity and it seems fine, how exactly are you meant to service the switch? The VIC is sounding off 3 series of 3 quick beeps with a pause between, along with 4 blinking wheels on the display, it says SERVICE 4WD SWITCH..

a70eliminator is offline   Reply With Quote Quick reply to this message
Unread 06-14-2013, 07:56 PM   #2
riot1987
Professional Wise Guy
 
riot1987's Avatar
1997 ZJ 
 
Join Date: Jun 2012
Location: Lakewood, COLORADO
Posts: 3,821
Step one, punch VIC in the face.
Step two, Remove broken, worthless, annoying VIC.


Fin.
__________________
http://www.jeepforum.com/forum/f22/riots-97-grand-1436100/

Build thread^^
riot1987 is offline   Reply With Quote Quick reply to this message
Unread 06-14-2013, 08:10 PM   #3
Cherokee95kid
Registered User
1995 ZJ 
 
Join Date: Aug 2011
Location: Reading, Pa
Posts: 600
I am too I just keep cleaning the switch itself and it helps a little but riot1987 is right the Vic does need to be punched in the face. Il be hard wiring my switch soon when i get time to do it which my dad thinks would work even though I keep telling him the Vic needs to get tossed as far as it can be into a junkyard and left there. The reason the msg keeps popping up is because of snotty soldering connections in the Vic I believe.
Cherokee95kid is offline   Reply With Quote Quick reply to this message
Unread 06-14-2013, 09:08 PM   #4
a70eliminator
Registered User
 
Join Date: Dec 2004
Location: Kent Ohio
Posts: 864
Loose the VIC! why?
How would I know if left a door ajar or the hatch ajar, sometimes I leave my signal on, low on coolant it lets me know, a light bulb out it lets me know, ever leave your hood ajar? washer fluid low, It has a nice calender clock.
Sure I could get by without it plus alot of other things like, the overhead console display, the dimming mirrors, auto lights, heated seats, ect.
If I mostly wheeled it then yea all that unessasary electronics and bling would be gone, nothing but a seat.
a70eliminator is offline   Reply With Quote Quick reply to this message
Unread 06-14-2013, 10:20 PM   #5
vonericsen
Registered User
1995 ZJ 
 
Join Date: Nov 2009
Location: Longmont, Colorado
Posts: 778
All i had to do to stop this message was disconnect the switch at the transfer case...
__________________
Moss Green 95 5.2l ZJ- 5.5" IRO lift, 255 75 R17 BFG M/T on JK Moabs, Mopar ECU, Mopar Tire Carrier
vonericsen is offline   Reply With Quote Quick reply to this message
Unread 06-14-2013, 10:54 PM   #6
StridAst
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: Clearfield, Ut
Posts: 56
I just unplugged both the red and black wires behind the VIC to stop that annoying message. Red are supposed to be plugged in for 249 t cases. and the black for 242. (never both. one should always be unplugged) I swapped my 249 for a 242. plugged the black wires together and poof instant service 4wd switch message every time I switch out of 2wd. (no message at all when I had the red wires plugged in). almost made me rip the thing out and back over it a few times. The switch is just trying to tell the VIC what you are in. If you have a 249 where your options are 4wd full time, neutral, or 4 low, then there really is no point whatsoever to having the message displayed. if you cant tell the difference between those 3 settings, then the VIC isn't likely to help If you have a 242 I suppose it would be nice, but hardly needed to tell you what you selected with the t case. unplug the wires and you can be done with it.

To fix the message and make things work properly. I know of two possibilities. either unplug then remove the switch from the transfer case, (really easy) then clean it, and reinstall it and see if the problem goes away. OR, remove the VIC, and start resoldering connections inside until you fix whatever loose connection somewhere inside that stupid pos box that was causing the problem. (not so easy)
StridAst is offline   Reply With Quote Quick reply to this message
Unread 06-15-2013, 12:06 AM   #7
tucsonzj
Registered User
2000 TJ Wrangler 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 2,188
Quote:
Originally Posted by riot1987 View Post
Step one, punch VIC in the face.
Step two, use the f***** search button!
step three, Remove broken, worthless, annoying VIC.
Step four, realize that by using the search function, you were a good JF member and get yourself a beer and admire your new 2wd cubby, light switches or cb radio that replaced the VIC
Step five, smile, while drinking that beer, because you used the search function and other members didn't have to see this thread...again.


Fin.
fixed it for you. Hm, I had this message once, I logged onto JF, used that rectangle in the top left called search, lone and behold, it had been covered 1,000 times and I didn't have to post another thread about it.

Now you may ask, why did I even bother looking or posting if all I was going to do was rant about you posting a thread that's been covered. Well it's 1am, I can't sleep, and I've seen this exact thread posted 100 times in the past year. Plus I like to do little rants.
__________________
"washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder."
tucsonzj is offline   Reply With Quote Quick reply to this message
Unread 06-15-2013, 07:32 AM   #8
a70eliminator
Registered User
 
Join Date: Dec 2004
Location: Kent Ohio
Posts: 864
That search function is the first thing I tried.
I clicked on the "search" in the upper right and then used the terms (Service 4WD) I got no hits. it did seems strange that no results were found, so I simply started a new thread. Thank you very much for attacking me over it.
a70eliminator is offline   Reply With Quote Quick reply to this message
Unread 06-15-2013, 08:07 AM   #9
tucsonzj
Registered User
2000 TJ Wrangler 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 2,188
Unless the search function was down, highly unlikely, in fact impossible you got 0 hits. Just saying.
__________________
"washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder."
tucsonzj is offline   Reply With Quote Quick reply to this message
Unread 06-15-2013, 09:03 AM   #10
rcMikeS1990
Registered User
1994 ZJ 
 
Join Date: Aug 2012
Location: Lincoln, Nebraska
Posts: 359
Quote:
Originally Posted by tucsonzj View Post
Unless the search function was down, highly unlikely, in fact impossible you got 0 hits. Just saying.
This is very true. Just search VIC in google, and voila, 10,000 vic threads pop up
__________________
1994 Grand Cherokee Limited 5.2L V8 318, Spectre cold air intake, Flowmaster Super44 muffler to 3.5" resonator tip, 30x9.5 BFG A/T's, Custom Tranny and TC shifter mod
My Build Thread--not sure how to make that the link-http://www.jeepforum.com/forum/f13/my-build-thread-1568707/
rcMikeS1990 is offline   Reply With Quote Quick reply to this message
Unread 06-17-2013, 01:00 AM   #11
eagsc7
Registered User
1994 ZJ 
 
Join Date: Apr 2013
Location: Sweetwater Cyt, WY
Posts: 432
Quote:
Originally Posted by a70eliminator View Post
That search function is the first thing I tried.
I clicked on the "search" in the upper right and then used the terms (Service 4WD) I got no hits. it did seems strange that no results were found, so I simply started a new thread. Thank you very much for attacking me over it.
That's Weird. Not that I don't believe you, but searching Just the ZJ Forums provided me with 239 results. 1 was yours, so 238 Other results to read. And this was Just using"Service 4WD" as the search terms.

Service 4WD Search results.
eagsc7 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.