serpentine belt wont go on zj 5.2 v8 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > serpentine belt wont go on zj 5.2 v8

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineToxic Brakes - 3000 PSI Braided Stainless Steel Brake LineCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 07-06-2013, 08:51 PM   #1
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
serpentine belt wont go on zj 5.2 v8

I just replaced the power steering bracket and now the serpentine belt wont go on like it did easily before. Now I'm looking for things that can be adjusted because the automatic belt tensioner wont move far enough to the right let the belt on.

Is there something that can be adjusted like a pulley or the alternator or AC?

webhostingdesig is offline   Reply With Quote
Unread 07-06-2013, 09:03 PM   #2
WhiteOut
Web Wheeler
 
WhiteOut's Avatar
1998 ZJ 
 
Join Date: Dec 2007
Posts: 8,015
Do you have it routed right? If it is the same belt that came off and you got the right pulley, it can't not go on.
WhiteOut is offline   Reply With Quote
Unread 07-06-2013, 09:13 PM   #3
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
Does anyone know the proper length of the serpentine belt for the 5.2L V8?
webhostingdesig is offline   Reply With Quote
Unread 07-06-2013, 09:14 PM   #4
WhiteOut
Web Wheeler
 
WhiteOut's Avatar
1998 ZJ 
 
Join Date: Dec 2007
Posts: 8,015
Is it the same belt that you took off? Or did you get a new one?
WhiteOut is offline   Reply With Quote
Unread 07-06-2013, 09:14 PM   #5
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
Quote:
Originally Posted by WhiteOut View Post
Do you have it routed right? If it is the same belt that came off and you got the right pulley, it can't not go on.
It's not the same belt, but before the power steering pump was broken so the pump was at an angle, essentially making the path less.

I will go compare the new belt to the old belt now, but do you know what the proper length is?
webhostingdesig is offline   Reply With Quote
Unread 07-06-2013, 09:22 PM   #6
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
Same belt length as the old belt, but we couldn't get it to go on after we replaced the power steering pump mounting bracket and pulley. The pulley is the same width as the old pulley. The only thing that is different is that the power steering pump isn't at an angle anymore so its 1/2" to 1" long path of travel now.

I'll try it again later tonight or tomorrow.

I just want to make sure that there isn't anything else I can adjust because the belt went on so easy before we changed the mounting bracket. Is it possible that I put the power steering mounting bracket on upside down and therefore changed something?
webhostingdesig is offline   Reply With Quote
Unread 07-06-2013, 09:23 PM   #7
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
Quote:
Originally Posted by WhiteOut View Post
Is it the same belt that you took off? Or did you get a new one?
I got a new one but I just checked and its the same length as the old belt. I'm kind of tired now so will revisit it a little later.

One thing I can think of is if its possible to bolt the bracket into the engine block upside down or sideways or is this pretty much impossible?
webhostingdesig is offline   Reply With Quote
Unread 07-06-2013, 09:40 PM   #8
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
is it possible to put the power steering pump bracket on backwards or flipped over/inversed or wrong in anyway?
webhostingdesig is offline   Reply With Quote
Unread 07-06-2013, 10:02 PM   #9
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 3,479
can you get the old belt on?
__________________
Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline   Reply With Quote
Unread 07-07-2013, 09:48 AM   #10
David97
Registered User
1995 ZJ 
 
Join Date: Dec 2012
Location: Wisconsin Dells, Wisconsin
Posts: 468
Shot in the dark, but are you moving the idler pulley over enough to get the belt on? lol
David97 is offline   Reply With Quote
Unread 07-07-2013, 11:50 AM   #11
AnotherRedZj
Registered User
1997 ZJ 
 
Join Date: Feb 2012
Location: fort walton beach, fl
Posts: 1,612
Your info says you have a V8 4. Something.....? Which is it? If a V8, then check to make sure the tensioner is in the correct position. I believe they have to be lined up right, iirc. And like said you can put the mounting bracket on wrong.

If a "4.something"......then, get a V8!
__________________
5.2 crate - fourwheelcustoms 2.25 BB - 31x10.50 BFG at-ko's 249/242 swap - front drive shaft upgrade by driveshaftspecialistincorporated - jcr off-road front bumper - engo 12k lbs winch......
AnotherRedZj is offline   Reply With Quote
Unread 07-07-2013, 12:49 PM   #12
sebian
Registered User
1995 ZJ 
 
Join Date: Sep 2009
Location: Austin, TX
Posts: 1,302
The problem I had when I did new PS pump and pulley was with the new aftermarket pulley. It would not seat all the way on the pump, causing an alignment issue. If this is your issue, you may need to find a different brand pump, or hit a junk yard for an oem pulley.
__________________
1995 ZJ 5.2L V8 318. 220,000 miles and still rollin.

List of parts not replaced yet:
...
sebian is offline   Reply With Quote
Unread 07-07-2013, 01:35 PM   #13
kensnelling
Registered User
1998 ZJ 
 
Join Date: Nov 2012
Location: Broken Arrow, OK
Posts: 490
Something I haven't seen mentioned yet, but did you get a new or used PS pump bracket? Were the casting numbers the same on both the new and the old? There were differences between 97/98 model bracket and earlier years. Different belts, too.

Ken
kensnelling is offline   Reply With Quote
Unread 07-07-2013, 02:00 PM   #14
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
Thanks guys. I have a V8 5.2L 4x4 Laredo. Everything is lined up perfectly, the new pulley is perfectly in alignment, mounted correctly and is the correct size.

Can someone tell me how to tell if my power steering bracket is mounted incorrectly (upside down or inversed)?







webhostingdesig is offline   Reply With Quote
Unread 07-07-2013, 02:02 PM   #15
webhostingdesig
Registered User
1997 ZJ 
 
Join Date: Oct 2007
Location: USA
Posts: 228
Quote:
Originally Posted by kensnelling View Post
Something I haven't seen mentioned yet, but did you get a new or used PS pump bracket? Were the casting numbers the same on both the new and the old? There were differences between 97/98 model bracket and earlier years. Different belts, too.

Ken
I bought this one.
http://www.ebay.com/itm/200910119023...S:3160&vxp=mtr

Old bracket was destroyed into little pieces. How can I tell without taking everything apart again?
webhostingdesig is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.