runs rough and i think my transfer is no good - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 09-12-2006, 10:58 AM Thread Starter
my94cherokee
Registered User
 
Join Date: Aug 2006
Location: New York
Posts: 35
runs rough and i think my transfer is no good

my 93 grand cherokee with the I6 auto is running rough still. ive done cap wires rotor plugs and CPS. its runing better then it was before but still rough at idle. any help would be great. also i drove the jeep about 180 miles one way and the truck seemed like it was hopping basically the sympotms of a bad vc in the transfer case. i have the 249 transfer case. i dont really know but again any help would be great. thanks in advance

my94cherokee is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-12-2006, 11:10 AM
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder
Posts: 23,086
The O2 sensor could probably stand to be replaced as well - aside from that what exactly is your question?

'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline  
post #3 of 3 Old 09-12-2006, 11:45 AM
phasewolf
Registered User
 
Join Date: Apr 2005
Location: Michigan
Posts: 277
Try cleaning the throttle body and make sure when you are doing it clean or replace the IAC. To clean the IAC you should remove it from the throttle body and get all the built up carbon out.
phasewolf is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
4.7 oil on plugs and runs rough HELP superjeep88 ZJ Grand Cherokee Forum 12 12-01-2008 05:19 PM
Engine runs rough michiganmaveric ZJ Grand Cherokee Forum 2 01-10-2008 06:33 AM
Runs Rough dannysandlin ZJ Grand Cherokee Forum 2 01-03-2007 02:10 PM
Help! 95 ZJ runs rough after it is warm. jmaier ZJ Grand Cherokee Forum 8 09-29-2006 02:37 PM
'93 Jeep Runs Rough & Hot KenE ZJ Grand Cherokee Forum 2 07-14-2005 07:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome