rpm's going up & down - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > rpm's going up & down

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Alloy usa heavy duty ball joint kitsWe have FLASHLIGHTS! Great for your Emergency bag!

Reply
Unread 08-12-2012, 08:32 PM   #1
jr4x4
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: riverhead, NY
Posts: 384
rpm's going up & down

when in park & i slowly rev engine once rpm's hit 3,500. the rpm's will swing back & forth from 3500 to 3000 when holding steady throttle. this dont happen at any other range under or above. i just replaced tps a month ago. engine seems to have a little stutter to it. aic is fairly new. could this be cam or crank sensor starting to go?? everything shows fine on my obd scanner, all monitors show good. i cant find nothing in the search. thanks guys

jr4x4 is offline   Reply With Quote Quick reply to this message
Unread 08-12-2012, 08:59 PM   #2
sevenscrew
Registered User
1997 ZJ 
 
Join Date: Mar 2011
Location: Hopatcong, New Jersey
Posts: 2,679
read my threads on idle problems recent couple pages I think.

I replaced my tps a month ago too. I'm having a up down rpm random hot or cold I think, and it spikes when switching to park and drops to 300 in drive.

going to check my iac for dirt. then replace the tps under advanced auto warranty
__________________
1997 Limited 5.2L 3 link front. np231 swap

in the works: lp30 + 8.8 build to 4.88s + wj swap
sevenscrew is offline   Reply With Quote Quick reply to this message
Unread 08-12-2012, 09:11 PM   #3
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,879
Quote:
Originally Posted by jr4x4 View Post
when in park & i slowly rev engine once rpm's hit 3,500. the rpm's will swing back & forth from 3500 to 3000 when holding steady throttle.
I'm not sure where i read it, but I know I read that holding over 2500 with no load can damage the engine. I'm sure someone is going to beat me up and tell me I'm wrong, but what the hell...
ZeeJay1997 is online now   Reply With Quote Quick reply to this message
Unread 08-12-2012, 09:22 PM   #4
jr4x4
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: riverhead, NY
Posts: 384
Quote:
Originally Posted by ZeeJay1997 View Post
I'm not sure where i read it, but I know I read that holding over 2500 with no load can damage the engine. I'm sure someone is going to beat me up and tell me I'm wrong, but what the hell...
its not something i do alot.lol. i was troubleshooting some stuff & noticed it
jr4x4 is offline   Reply With Quote Quick reply to this message
Unread 08-13-2012, 11:37 AM   #5
jr4x4
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: riverhead, NY
Posts: 384
ok. i replaced tps sensor (mopar) & its still doing it . my scanner is saying all monitors are ok. except i noticed it said o2 sensor heater is incomplete. but says o2 sensor monitors are ok,evap monitors ok everything ok but o2 heater. and also now if i crank engine real quick but dont start it it will like blow a rush of air out throttle body. like (swuch). engine idles fine except what feels like a little stutter. the back & forth rpm's only at 3500 holding steady throttle the tack will go up& down 500 rpm's. almost like a rev limiter. almost like toming is off. scanner says adv.ign. is like arund 17 degrees at idle. & will go up as much as 40 degrees when driving. i had the pcm reflashed last year as a recall. i feel like they messed something up. since then i cant fix or find this tink/clinking noise at idle sounds like bellhousing but with stethascope the clink sounds real hollow metallic right around base of oil dipstick tube where it goes into block. i some how feel this is all related. so what do ya guys think.LOL.... by the way. THANK YOU ALL..
jr4x4 is offline   Reply With Quote Quick reply to this message
Unread 08-13-2012, 12:08 PM   #6
sevenscrew
Registered User
1997 ZJ 
 
Join Date: Mar 2011
Location: Hopatcong, New Jersey
Posts: 2,679
not sure but until someone else replies, check underneath to make sure the o2 sensor wires arent burned
__________________
1997 Limited 5.2L 3 link front. np231 swap

in the works: lp30 + 8.8 build to 4.88s + wj swap
sevenscrew is offline   Reply With Quote Quick reply to this message
Unread 08-13-2012, 07:26 PM   #7
jr4x4
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: riverhead, NY
Posts: 384
Quote:
Originally Posted by sevenscrew View Post
not sure but until someone else replies, check underneath to make sure the o2 sensor wires arent burned
yea i did that today & checked them both with multimeter & their fine. there NTK & 1 year old. oh & as far as rpm's going up & down i swapped out my aic with one i had laying around & the problem is like 90% gone. but still there
jr4x4 is offline   Reply With Quote Quick reply to this message
Unread 08-13-2012, 07:43 PM   #8
sevenscrew
Registered User
1997 ZJ 
 
Join Date: Mar 2011
Location: Hopatcong, New Jersey
Posts: 2,679
ok heres what mine does, if its going up and down in park(like today, AFTER cleaning the iac, made no difference) if i step on the gas quick to 3k and let off real quick itll fall to 1k then stop, then fall to normal idle around 6-700 ish in park and not surge.
__________________
1997 Limited 5.2L 3 link front. np231 swap

in the works: lp30 + 8.8 build to 4.88s + wj swap
sevenscrew is offline   Reply With Quote Quick reply to this message
Unread 08-13-2012, 11:18 PM   #9
jr4x4
Registered User
1996 ZJ 
 
Join Date: Mar 2011
Location: riverhead, NY
Posts: 384
Quote:
Originally Posted by sevenscrew View Post
ok heres what mine does, if its going up and down in park(like today, AFTER cleaning the iac, made no difference) if i step on the gas quick to 3k and let off real quick itll fall to 1k then stop, then fall to normal idle around 6-700 ish in park and not surge.
that ^ might be your aic. my rpm's hold steady everywhere except at 3500. if i try holding throttle steady at 3500 the engine will rev back & forth from 3500 to 3000 back & forth over & over. but only at that spot.
jr4x4 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.