RPM at engine start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 12-08-2011, 05:36 PM Thread Starter
bigbill888
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: michigan
Posts: 969
RPM at engine start

My 4.0 ZJ has generally ran up to 1500 rpm upon starting and settles down to 700 within about 2 seconds. The last couple weeks, it just starts up and is at 700 RPM without the run-up after firing. The engine has 300K miles and I doubt the IAC has ever been looked at. Was it starting normally before, or is the new startup correct? Is this caused by the IAC?


96 ZJ Laredo, 4.0, 242, 230K
95 ZJ Limited, 4.0, 242, 140K
98 XJ Sport, 4.0, 231, 140K
All work well
bigbill888 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-08-2011, 05:41 PM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,801
Clean or replace the IAC/ throttlebody and run some seafoam through the engine.
PolkaPower is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
4.0 Engine Won't start RussellZJ98 ZJ Grand Cherokee Forum 24 01-11-2011 07:57 PM
4.0 Engine Won't start RussellZJ98 ZJ Grand Cherokee Forum 0 01-06-2011 04:06 PM
engine will not start nickp ZJ Grand Cherokee Forum 1 07-03-2008 01:02 AM
I can't start the engine Decatur ZJ Grand Cherokee Forum 5 10-13-2007 02:30 PM
Longer than normal engine crank time prior to engine start tsb blizzboy283 ZJ Grand Cherokee Forum 7 10-15-2005 11:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome