Rpm drops then dies - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Rpm drops then dies

Year End Clearance Sale! Save 20%NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 01-14-2013, 03:27 PM   #1
duhkooter
Registered User
1994 ZJ 
 
Join Date: Sep 2012
Location: agawam, Ma
Posts: 22
Rpm drops then dies

when i start up my 5.2 it will idle perfectly fine if i leave it in park, if i drop it into drive it will idle for about 5 - 10 minutes before the rpms slowly drop to about 100 then it will die. if i try to start it immediately it wont crank over and the my battery gauge says my battery is nearly dead, but if i wait about 30 minutes or so shell fire right up again.

duhkooter is offline   Reply With Quote Quick reply to this message
Unread 01-15-2013, 08:00 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,905
Sounds a lot like a bad battery or weak charging system.
ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 01-15-2013, 09:46 PM   #3
papitt
Registered User
1995 ZJ 
 
Join Date: Dec 2008
Location: Stephenville Texas 76401, Texas
Posts: 710
What kind of battery do you have. I had a gel battey that was bad and did that to me on a chevy years ago.
..
papitt is offline   Reply With Quote Quick reply to this message
Unread 01-15-2013, 09:53 PM   #4
duhkooter
Registered User
1994 ZJ 
 
Join Date: Sep 2012
Location: agawam, Ma
Posts: 22
I've tries jumping it multiple times after it died and it did work either time, so I'm not quite sure it's my batter or a charging system.
duhkooter is offline   Reply With Quote Quick reply to this message
Unread 01-15-2013, 10:43 PM   #5
Bannerman53
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Wilmington, NC
Posts: 73
check all your grounds, sounds like some sort of wiring/electrical problem
Bannerman53 is offline   Reply With Quote Quick reply to this message
Reply

Tags
5.2l , rpm , stalling

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.