Right front suspension banging and knocking...control arms? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 07-13-2013, 01:36 PM Thread Starter
ErikTheRad
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Marysville
Posts: 420
Right front suspension banging and knocking...control arms?

Its been an issue since I got the Jeep almost 5 years ago, but now with the new OME springs and ProComp shocks, its worse. When on the rocky/bumpy trails, theres a banging and knocking at the right front corner. It sounds like something is broken and slopping around, I can even sometimes hear an echo in the spring-- but its been inspected a bazillion times and nothing is broken or loose or missing. Driving on the smooth road there are no issues and it handles great, just the noises when on bumps. I suspect possibly the 160k+ mile factory control arm bushings are worn and slopping around? Any advice would be great before I start throwing money at parts. Thanks!

ErikTheRad is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-13-2013, 02:25 PM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,371
Quote:
Originally Posted by ErikTheRad View Post
Its been an issue since I got the Jeep almost 5 years ago, but now with the new OME springs and ProComp shocks, its worse. When on the rocky/bumpy trails, theres a banging and knocking at the right front corner. It sounds like something is broken and slopping around, I can even sometimes hear an echo in the spring-- but its been inspected a bazillion times and nothing is broken or loose or missing. Driving on the smooth road there are no issues and it handles great, just the noises when on bumps. I suspect possibly the 160k+ mile factory control arm bushings are worn and slopping around? Any advice would be great before I start throwing money at parts. Thanks!
If the control arms have never been serviced that is 100% a problem if not the problem.
Other things it could be are motor mounts and transmission mounts. They should be replaced at the same time.
Swaybar endlinks like to clunk when they go bad. The sway bar bushings should be looked at too.
Your battery isn't bouncing around in there is it?

Here are mine at 127. The center isn't even attached. Just sitting in there. My motor mounts were that bad or worse too. Especially on the drivers side.
PolkaPower is online now  
post #3 of 7 Old 07-13-2013, 06:26 PM Thread Starter
ErikTheRad
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Marysville
Posts: 420
Yes, I'm sure it could use engine and trans mounts, those are just as old as everything else. But the clunking and banging is definately in the suspension. I'm gonna order new bushings for the sway bar end links, a new steering damper, and I think I'm gonna do all 4 front control arms. The replacement on these looks pretty straight-forward, made easier with a good impact gun. While Im in there I should replace both front CV axles too.
ErikTheRad is offline  
post #4 of 7 Old 07-13-2013, 06:27 PM Thread Starter
ErikTheRad
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Marysville
Posts: 420
That pic is of your control arm bushing, correct?
ErikTheRad is offline  
post #5 of 7 Old 07-13-2013, 06:55 PM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,371
Yes that is the control arm bushing. Don't replace the axles unless the boots are torn. They are still good if the boots are intact. Do one arm at a time and mark the cam bolts with a marker so you can put them back at the same angle. I did all the lowers at one time then the uppers later. The uppers do not see near the amount of stress as the lowers. It made a night and day difference in the way it handled and felt.
PolkaPower is online now  
post #6 of 7 Old 07-13-2013, 08:55 PM
newfieZJ
Registered User
1995 ZJ 
 
Join Date: May 2008
Posts: 6,557
Quote:
Originally Posted by ErikTheRad View Post
That pic is of your control arm bushing, correct?
My experience

http://www.jeepforum.com/forum/f13/w...-like-1027823/
newfieZJ is offline  
post #7 of 7 Old 07-14-2013, 04:42 AM Thread Starter
ErikTheRad
Registered User
1993 ZJ 
 
Join Date: May 2010
Location: Marysville
Posts: 420
Unfortunately for me, the CV boots are torn. Bofadem. Also have the obnoxious clicking when turning. They need to be replaced.

Newfie, thanks for the link. Great info and pretty much confirms my suspension suspicions.
ErikTheRad is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome