Revs real high like gas pedal is stuck! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 15 Old 07-19-2011, 04:24 PM Thread Starter
D3V0311
Registered User
1997 ZJ 
 
Join Date: Jan 2011
Location: Canal Fulton
Posts: 80
Revs real high like gas pedal is stuck!

97 grand cherokee laredo 4.0L 6cyl. select track 4x4.....131,000 miles...

aight so heres the low down, i drove to my parents house twice today (back n forth) to move some stuff, ran fine all day, soon as i was leaving turned it on like normal and the rpms went wayy up like i was stepping on the gas.thought it was odd so i just it off n started again. same thing as soon as put it into drive it jerked (such high rpms) but my foot was on the brake and the rpms went back down to about 1000. so when its in park or neutral itll rev super high but when in drive its fine..the issue is when i let off the brake the jeep wants to drive its self, it accelerates and even shifts fine but i dont have to even have my foot on the pedal... i looked to see if the throttle cable was stuck and it doesnt appear to be, also my display center is flashing like the battery went dead or disconnected, cables and terminals are really tight and clean, but all my radio stations are still preset...any body got any ideas of wtf is goin on?...no check engine light on

D3V0311 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 07-19-2011, 07:12 PM Thread Starter
D3V0311
Registered User
1997 ZJ 
 
Join Date: Jan 2011
Location: Canal Fulton
Posts: 80
anybody got any ideass???
D3V0311 is offline  
post #3 of 15 Old 07-19-2011, 07:28 PM
Ohno50
Registered User
1998 ZJ 
 
Join Date: Feb 2011
Location: Bunnell
Posts: 3
Could be the Idle air controller or an vacuum leak if it's constant
Ohno50 is offline  
post #4 of 15 Old 07-19-2011, 07:34 PM Thread Starter
D3V0311
Registered User
1997 ZJ 
 
Join Date: Jan 2011
Location: Canal Fulton
Posts: 80
if i had a vaccuum leak wouldnt it act up when its in drive also?
D3V0311 is offline  
post #5 of 15 Old 07-19-2011, 07:48 PM
Ohno50
Registered User
1998 ZJ 
 
Join Date: Feb 2011
Location: Bunnell
Posts: 3
It's just more noticeable with no load. It slams into gear when the RPMs are higher, but the then it's not as noticeable. Depends on how big the leak is. The higher RPMs means the engine is getting more air from somewhere. Which to me means IAC or a leak. IAC could be intermittent.
Ohno50 is offline  
post #6 of 15 Old 07-19-2011, 08:18 PM Thread Starter
D3V0311
Registered User
1997 ZJ 
 
Join Date: Jan 2011
Location: Canal Fulton
Posts: 80
im gunna pull the IAC and check it here in a minute, how would i diagnose a vac leak or where one is at
D3V0311 is offline  
post #7 of 15 Old 07-19-2011, 08:23 PM
Ohno50
Registered User
1998 ZJ 
 
Join Date: Feb 2011
Location: Bunnell
Posts: 3
Check all you vac lines. Look for a cracked/broken tube. Or a tupe tgat has been pulled from the intake. If it's bad enough you'll hear the hissing.
Ohno50 is offline  
post #8 of 15 Old 07-19-2011, 08:34 PM
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 5,063
a vacumm leak would make a hiss if its really bad, and rpm's can be high when its leaking.

2013 6.2 V8 Camaro SS 30k
98 5.9 V8 ZJ 180k
98 4.0 I6 ZJ 240k
90 5.9 SJ Grand Wagoneer 110k
Candymancan is offline  
post #9 of 15 Old 07-19-2011, 10:05 PM Thread Starter
D3V0311
Registered User
1997 ZJ 
 
Join Date: Jan 2011
Location: Canal Fulton
Posts: 80
could id screw up anything else if i drive it like this till i get it figured out..i have to have a vehicle to drive
D3V0311 is offline  
post #10 of 15 Old 07-20-2011, 05:37 AM
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 5,063
I dont think so, just your gas mileage lol. How high is it reving exactly ?

2013 6.2 V8 Camaro SS 30k
98 5.9 V8 ZJ 180k
98 4.0 I6 ZJ 240k
90 5.9 SJ Grand Wagoneer 110k
Candymancan is offline  
post #11 of 15 Old 07-20-2011, 07:26 AM
melk
Registered User
1996 ZJ 
 
Join Date: Sep 2009
Location: Charlotte
Posts: 2,890
Pull off your battery cables to force the PCM to reset.
melk is offline  
post #12 of 15 Old 07-20-2011, 07:32 AM
woodscavenger
Registered User
1997 TJ Wrangler 
 
Join Date: May 2011
Location: boise
Posts: 38
Check the VIN, maybe it's really a Toyota
woodscavenger is offline  
post #13 of 15 Old 07-20-2011, 08:08 AM
97zjdriver
Registered User
1997 ZJ 
 
Join Date: Apr 2011
Location: binghamton
Posts: 91
It sounds like the tps. Had the same problem when I was in nc. It got wet and would idle realy high intill it was in gear. Bought one at the parts store for like 56 bucks but it fixed it. You could also try to put a hole in it to try to let it dyr out if it may have gotten wet

Sent from my Droid using JeepForum
97zjdriver is offline  
post #14 of 15 Old 07-20-2011, 01:11 PM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,793
If it is slamming into gear it WILL destroy the transmission very soon. These transmissions don't take shock loads well at all.

Find the leaks soon or pay the price.

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline  
post #15 of 15 Old 07-20-2011, 02:08 PM
Midnightluckey
Registered User
1995 ZJ 
 
Join Date: May 2009
Location: Houston, TX
Posts: 1,327
Quote:
Originally Posted by woodscavenger
Check the VIN, maybe it's really a Toyota
Ha. Give this man a beer.

95 Limited Chargold ZJ 5.2L -5.5" lift (IRO, Ironman, and RC parts), 33" BFG M/T's, 15x8 procomp crawlers, 242 swap, 2 12" subs, 1000w amp, cherry bomb, full skid package, Kevins rear stealth bumper clone w 3/4" D rings, Rlcwelding front bumper w 3/8" D rings, XRC-8, front tow hooks, 2 daylighter fairlead lights, 2 daylighter windsheild lights, 2 55w driving lights, OBA, Cobra 18 CB, dual 4' whips, RC disconnects, smittybuilt jack, optima yellowtop.
Built not bought #512
Midnightluckey is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
WJ 2000 4.7 Multiple High Revs On Startup Jerry1964 ZJ Grand Cherokee Forum 5 04-02-2010 07:30 PM
Heater blows warm at low rpm, hot at high revs? streetzj ZJ Grand Cherokee Forum 4 12-08-2009 01:48 PM
revs up without pressing gas pedal...... texasguy2000 ZJ Grand Cherokee Forum 7 11-11-2008 08:17 PM
WJ High Revs First 300 yards TORMULA ZJ Grand Cherokee Forum 12 06-03-2007 11:45 AM
Commander revs high after start Vizcad WK Grand Cherokee & XK Commander Forum 2 05-07-2006 12:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome