Repairing headlight switch that causes dimming issues *picture heavy* - Page 6 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #76 of 162 Old 01-23-2013, 09:26 PM
APD
Registered User
1998 ZJ 
 
Join Date: Jun 2009
Location: SLC, UT
Posts: 104
Thanks sniperdude! I've been battling this ever since 2002. I finally fixed it tonight after reading this thread. now it's on to the VIC "bad coolant sensor" message. i'm guessing it should be the same procedure as this.

APD is offline  
Sponsored Links
Advertisement
 
post #77 of 162 Old 01-28-2013, 11:23 PM
Ripper3494
Registered User
1994 YJ Wrangler 
 
Join Date: Jan 2010
Location: Warrenville
Posts: 5,741
great looking write up, i will be doing this soon, my dash lights flicker non stop

build thread:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1994 yj stretched, locked and loaded - 6.0l vortec lq4, 4l60e, np231, Dana 44s 37" interco trxus m/t, 3.5" bds front leafs, double triangulated 4 link rear on xj front coils.
1997 ZJ limited - BONE stock
2003 tj - 4in skyjacker, 33" mickey thompsons
my on board alternator/welder write up

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

my tj 1/2 doors on a yj write up

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

RC vs BDS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ripper3494 is offline  
post #78 of 162 Old 05-08-2013, 01:23 PM
Giallo
Registered User
1998 ZJ 
 
Join Date: May 2013
Location: Florence
Posts: 55
Hello,
I wanna thank you for this wonderful guide, you solved me a big problem: ZJ 5.9 are really rare cars here in Italy and I was not able to find the spare part, neither from Official Chrysler nor on Ebay.
So, doing some search on Internet I found this topic and fixed the problem. You have a beer paid when you come to Florence.
Giallo is offline  
post #79 of 162 Old 07-15-2013, 08:02 AM
cooky
Registered User
1997 ZJ 
 
Join Date: Mar 2013
Location: WINNIPEG
Posts: 8
Great instructions! Thanks, worked like a charm.
$165 saved(dealer price)!!!
cooky is offline  
post #80 of 162 Old 08-29-2013, 09:02 PM
bigchieftaco
Registered User
2005 WK 
 
Join Date: Jul 2013
Location: Humboldt
Posts: 151
Just did mine!!! I was just about to order a new one for $85!! Thanks a ton
Took me about 30 minutes total. Longest part was taking the dash halfway apart
bigchieftaco is offline  
post #81 of 162 Old 09-01-2013, 02:37 PM
JFcavedweller
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2010
Location: Lynchburg
Posts: 417
and this is why I support jeepforum. thanks sniperdude!

O|||||||O - '99 TJ
■|||||||■ - '97 ZJ
JFcavedweller is offline  
post #82 of 162 Old 09-19-2013, 12:50 PM
PHARIS88
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Fairview / Allen
Posts: 548
SO haven't had much time to work on the jeep, b/c I recently got engaged... and then couple weeks after I found out we are having a baby! So, I have been extremely busy and I FINALLY had 20 minutes to tackle SOMETHING on my jeep... I did this in 15 mins, the biggest PITA was getting it out of the dash lol

Thank you so much for this write up!!! Fixed the flashing and the AUTO headlights!

Anybody can be become an American, you have to be BORN TEXAN!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PHARIS88 is offline  
post #83 of 162 Old 10-07-2013, 04:29 PM
kahl452
Registered User
1996 ZJ 
 
Join Date: Oct 2013
Location: 29 Palms
Posts: 34
It took me about an hour to do. Mainly because I was stalling through out the process. Picked up a 10$ soldering kit that had some wire in it from radio shack. It worked! my dashboard doesn't turn off and on anymore! Thanks for pictures, they really helped.
kahl452 is offline  
post #84 of 162 Old 10-12-2013, 11:46 AM
Oleschool
Registered User
1998 ZJ 
 
Join Date: Sep 2013
Location: Fort Smith
Posts: 5
I don't have the Auto feature but have the fog lights and am experiencing the same random dimming.Does this fix work for other headlight switches as well?
Oleschool is offline  
post #85 of 162 Old 10-12-2013, 02:57 PM
ejschultz
Web Wheeler
 
ejschultz's Avatar
2001 TJ Wrangler 
 
Join Date: Feb 2010
Location: Cedar Lake
Posts: 3,485
Yup. It fixed mine with auto headlights and fogs.

Edit: Obviously I misread your post...

01 TJ - 4.0L, NV3550, 2" Skyjacker budget boost, Trail Gear front bumper, 31" Duratracs on 15x8s
ejschultz is offline  
post #86 of 162 Old 10-13-2013, 12:25 PM
JFcavedweller
Registered User
1999 TJ Wrangler 
 
Join Date: Aug 2010
Location: Lynchburg
Posts: 417
Quote:
Originally Posted by Oleschool View Post
I don't have the Auto feature but have the fog lights and am experiencing the same random dimming.Does this fix work for other headlight switches as well?
it works for all combinations. a good test is that if you can press in on the switch and the lights come back, then you can almost guarantee it's the solder joints. (if they don't come back it doesn't mean the joints aren't bad)

O|||||||O - '99 TJ
■|||||||■ - '97 ZJ
JFcavedweller is offline  
post #87 of 162 Old 10-13-2013, 01:08 PM
KiloWatts
Registered User
1996 ZJ 
 
Join Date: Aug 2013
Location: Philadelphia
Posts: 207
I did this and it worked like a charm.
KiloWatts is offline  
post #88 of 162 Old 10-13-2013, 02:07 PM
Martin600
Registered User
1997 ZJ 
 
Join Date: Jun 2013
Location: Perth
Posts: 75
I recently did this fix as well, before I even saw this thread

I didn't take my circuit board out the casing, or the knobs off. Just the main solder joints I reflowed near the connector block.

I've got regular lights on my limited, with 2 (front and rear) fog light switches.
Martin600 is offline  
post #89 of 162 Old 10-21-2013, 10:26 AM
JeepishMama
Registered User
1998 ZJ 
 
Join Date: Oct 2013
Location: Ephrata
Posts: 1
Awesome fix! Those flickering lights were annoying as hell.... but I ran into an un/related problem. I doubt this job caused this cause this part doesn't have anything to do with turn signals BUT now my rear turn signals/hazards don't work The front ones just blink twice as fast... fuse? relay? Did I bump a wire?! Anyone have any idea what could cause just the rear hazards/blinkers to both go out?
JeepishMama is offline  
post #90 of 162 Old 10-21-2013, 11:05 AM
zacko-zj
Registered User
1998 ZJ 
 
Join Date: Oct 2013
Posts: 52
Rednecks rule! I love it when you can fix things.
zacko-zj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Headlight issues in my ZJ Flyinbrick ZJ Grand Cherokee Forum 4 02-04-2009 12:24 PM
Headlight question / picture request Kota04SXT ZJ Grand Cherokee Forum 21 08-07-2008 08:48 PM
07 CRD w/ Heavy Bullbar - Suspension Issues? basthen WK Grand Cherokee & XK Commander Forum 15 07-22-2008 07:28 PM
KOR/Kolak H4 Headlight Upgrade *Pic Heavy* KingPrat ZJ Grand Cherokee Forum 11 12-12-2006 10:19 PM
Jason's Sliders - Picture heavy njrealtor55 ZJ Grand Cherokee Forum 23 09-30-2005 04:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome