Relay failure? (electrical problem) - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Relay failure? (electrical problem)

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 11-20-2006, 02:23 PM   #1
retrovoice
Registered User
 
Join Date: Nov 2006
Location: Huntsville, AL
Posts: 4
Relay failure? (electrical problem)

I have a 99 GC with an electrical problem that started three days ago.

On three occasions when I turned off the ignition (after driving) the power to the interior electrical system failed. It wasn't completely dead. There was a constant clicking sound that seemed to come from under the dash occuring around 2-4 Hz. The dials on the instrument cluster were moving randomly. The light under the driverside dash was dim and flickering at the same frequency of the clicking sound.

Except for the random movement of the gauges and the clicking sound, the vehicle behaved as if there was no electrical power. Actuating the RF remote had no effect either.

This first happened when I arrived at a local Target store. I went inside to shop and when I came back out 20 minutes later, everything was back to normal. I started the Jeep and drove home. Everything worked fine. The clock on the radio did reset though, consistent with loss of power.

Any help is appreciated.

retrovoice is offline   Reply With Quote Quick reply to this message
Unread 11-20-2006, 05:48 PM   #2
MtnbikerWJ
Registered User
 
Join Date: Jan 2005
Location: Lakewood, CO
Posts: 570
I would start by checking for loose or corroded battery connections.
__________________
[SIZE="1"]04' WJ Laredo 4.0L 4x4
245/75-16 GY MTR's
Rusty's 2" BB
ARB Bull Bar with Piaa 520 drivings, no winch yet though
Kenwood Headunit, Kenwood Sirius Reciever, RF Punch p2002 Amp, RF Punch 10" Sub enclosure
Hypertech power programmer
K&N 77 series FIPK
Flowmaster 50 SUV
Magnaflow Cat
next gears and lsd's and OME coils[/SIZE]

[CENTER][COLOR=Green]Colorado Jeep Club Member #14[/COLOR][/CENTER]
[COLOR=White][CENTER]White Jeep Club Member #114[/CENTER][/COLOR]
MtnbikerWJ is offline   Reply With Quote Quick reply to this message
Unread 11-20-2006, 10:44 PM   #3
retrovoice
Registered User
 
Join Date: Nov 2006
Location: Huntsville, AL
Posts: 4
The battery connections are clean (no corrosion) and the cables are solidly attached. When the problem's not occuring, the battery power is strong, starts the car without problem, and everything functions fine.
retrovoice is offline   Reply With Quote Quick reply to this message
Unread 11-21-2006, 09:28 PM   #4
1 Long CJ
Registered User
2006 LJ Wrangler 
 
Join Date: Nov 2005
Location: SW Illinois
Posts: 267
I had something similar going on when one of my taillight sockets shorted out. I think it got wet. Just check if all your lights are working.
__________________
Life is short. Play hard.

1979 CJ5, 1982 CJ8, 2004 WJ, 2006 LJ Rubicon
1 Long CJ is offline   Reply With Quote Quick reply to this message
Unread 11-22-2006, 10:43 AM   #5
retrovoice
Registered User
 
Join Date: Nov 2006
Location: Huntsville, AL
Posts: 4
Thank you for the suggestion. I'll check out the lights. It's been 4 days since the problem last occured. If it was due to some moisture causing a short, then maybe the problem has, for the moment, cured itself.
retrovoice is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.