rear wiper motor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > rear wiper motor

Year End Clearance Sale! Save 20%NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 12-27-2005, 10:27 AM   #1
Maciej
Registered User
 
Join Date: Aug 2005
Location: Poland
Posts: 89
rear wiper motor

My rear wiper is not working. Probably because of dust in axle. Maybe someone has removed rear wiper motor and made some repair? I will be glad to receive some tips.

__________________
________________
96 ZJ 5,2
2,5'' BB, DTs3000, 31 BFG MT
LPG

[URL="http://community.webshots.com/photo/550704770/2859657980076956703LOySOe#"]http://community.webshots.com/photo/550704770/2859657980076956703LOySOe#[/URL]
Maciej is offline   Reply With Quote Quick reply to this message
Unread 12-27-2005, 10:35 AM   #2
Phil Gerard
Former Mod
 
Phil Gerard's Avatar
1995 ZJ 
 
Join Date: Jan 2004
Location: NJ
Posts: 2,503
Here ya go:

http://www.nagca.com/grandtech/rearwiperrepair.htm

Phil
__________________
'95 ZJ Ltd. White 4.0L
TW DC DS; ARB Bull Bar, F&R Air Lockers; Superior Axles; Warn Winch; 4.56 gears; ACOS, Addco F&R Sw Bar, JKS Discos, Rr Track Bar & Nerfs, 249>242 Swap, Stillen rotors+Kolak pads, 3 pc. Armor, RE 4.5 Kit + 2.5"BB, Adj. UCAs&LCAs, OME SS, Bilstein 5150s, 15x8 AR Diamond Backs, 33 Truxus MTs, K&N FIPK, RE 62mm TB, Perf. Distr. 4.0L Kit, Exhaust: 2.5" Kolak exhaust FM 70: Optima Yellow, Mean Grn Alt., PIAA 520s, 540s, Kevins Rack, & TB Conversion
Phil Gerard is offline   Reply With Quote Quick reply to this message
Unread 12-29-2005, 07:38 AM   #3
Maciej
Registered User
 
Join Date: Aug 2005
Location: Poland
Posts: 89
many thanks!!!
__________________
________________
96 ZJ 5,2
2,5'' BB, DTs3000, 31 BFG MT
LPG

[URL="http://community.webshots.com/photo/550704770/2859657980076956703LOySOe#"]http://community.webshots.com/photo/550704770/2859657980076956703LOySOe#[/URL]
Maciej is offline   Reply With Quote Quick reply to this message
Unread 12-29-2005, 09:54 PM   #4
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,433
I too thought that my motor was not working once a long time ago. In actuality, my rear hatch does not close fully on every fourth or fifth slam. The door seems shut, but it is not fully closed. Every time I use the gate, I turn the wiper on to see if it is fully shut. If it is shut correctly, then the wiper will work. If not, then it will not work. I think that the previous owner damaged the hinge by over-stressing it. The hinge alignment is just such that it does not close perfectly every time.
__________________
'06 XK Limited, 5.7L, QD II, Black, 128K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 104K
kentman is offline   Reply With Quote Quick reply to this message
Unread 01-03-2006, 10:14 AM   #5
Maciej
Registered User
 
Join Date: Aug 2005
Location: Poland
Posts: 89
I have done it! It was very hard to remove wiper shaft. I thought it will be not possible and using hammer was so. I used vise BUT very carefully. Now my wiper works very fast and like new one! I think important is to repair before wiper stops forever. My stopped. If anyone needs help I will!
__________________
________________
96 ZJ 5,2
2,5'' BB, DTs3000, 31 BFG MT
LPG

[URL="http://community.webshots.com/photo/550704770/2859657980076956703LOySOe#"]http://community.webshots.com/photo/550704770/2859657980076956703LOySOe#[/URL]
Maciej is offline   Reply With Quote Quick reply to this message
Unread 01-03-2006, 02:08 PM   #6
bobiam
Registered User
 
Join Date: Nov 2005
Location: Unionville, CT
Posts: 72
These things are troublesome.......... There is an adjustment on the unit that can fine tune it (with the plastic off the inside of the hatch), but if like mine it was a waste of time and I had to replace it. The dealer had it in stock (re-mfg) and said that it's a common replacement. The shaft on mine was fine. It was internal.
Bob
bobiam is offline   Reply With Quote Quick reply to this message
Unread 01-05-2006, 10:58 PM   #7
canadia_driver
Registered User
 
Join Date: Jun 2004
Location: guelph, canada
Posts: 225
i have an extra motor if anyone needs, PM if u want it
canadia_driver is offline   Reply With Quote Quick reply to this message
Unread 02-13-2006, 01:02 PM   #8
acitydweller
Registered User
 
Join Date: May 2004
Posts: 168
i May need one... going to try reconditioning mine first...

finger crossed.

btw, thanks for the reference. Heaps of help!
acitydweller is offline   Reply With Quote Quick reply to this message
Unread 02-13-2006, 01:10 PM   #9
canadia_driver
Registered User
 
Join Date: Jun 2004
Location: guelph, canada
Posts: 225
sorry too late already sold it, normally u can get the old one working tho, ive done 3 motors and the only reason i had to buy a new one was because i was stupid and hit the shaft with a hammer and the nut wouldnt fit on afterwards
canadia_driver is offline   Reply With Quote Quick reply to this message
Unread 02-14-2006, 06:52 AM   #10
acitydweller
Registered User
 
Join Date: May 2004
Posts: 168
ok, ill have a go at fixing this one. it works sometimes...not the times you need it

i also noticed that i dont ahve the end cap / cover to the base of the rear wiper. is this something i can buy separately or do i need a whole wiperarm assembly?

thanks
acitydweller is offline   Reply With Quote Quick reply to this message
Unread 02-16-2006, 11:12 AM   #11
acitydweller
Registered User
 
Join Date: May 2004
Posts: 168
Hey, Can anyone tell me exactly where on the trunk lid are these hidden screws? knowing me and my heavy hand, i may end up tearing out the lid cover.

thanks in advance.
acitydweller is offline   Reply With Quote Quick reply to this message
Unread 02-16-2006, 12:21 PM   #12
canadia_driver
Registered User
 
Join Date: Jun 2004
Location: guelph, canada
Posts: 225
there are two screw behind the carpet near the bottom left and right corners, if u feel around you should feel the cuts in the carpet where teh screws are
canadia_driver is offline   Reply With Quote Quick reply to this message
Unread 02-17-2006, 10:56 AM   #13
acitydweller
Registered User
 
Join Date: May 2004
Posts: 168
Awesome. Youve been a great help Canadia driver.

thanks!
acitydweller is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.