Really low idle, not sputtering or dying? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Really low idle, not sputtering or dying?

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 08-05-2012, 08:01 PM   #1
Murdered0utGC
Registered User
2000 WJ 
 
Join Date: Jul 2012
Location: Omaha, Nebraska
Posts: 11
Really low idle, not sputtering or dying?

Hey guys , I have a 96 GC Limited with the 5.2 in it, and when I start it up, it starts perfect, but once I start going, whenever I stop at a stop sign or a light, it idles at like maybe 300-400 rpms? the very first line on the tachometer above zero. It NEVER dies, NEVER sputters, idles just perfect. Is this something I should be worried about?

Murdered0utGC is offline   Reply With Quote
Unread 08-06-2012, 01:33 AM   #2
plafranx
Registered User
1995 ZJ 
 
Join Date: Mar 2012
Location: Hillsboro, Oregon
Posts: 36
Try cleaning your idle air controller (IAC) and throttlebody. Mine Idles perfectly now.
__________________
Let's bust a nut
plafranx is offline   Reply With Quote
Unread 08-06-2012, 01:58 AM   #3
Grand_ZJ
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2011
Location: Las Vegas, Nevada
Posts: 1,007
^ I agree. Usually a low idle problem is a case of a dirty TB.
Grand_ZJ is offline   Reply With Quote
Unread 08-06-2012, 08:17 AM   #4
iser
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Location: Fairbanks, AK
Posts: 675
seafoam. i am a believer.
__________________
[B]- REST IN PEACE, RATMONKEY - [/B]

[URL="http://www.jeepforum.com/forum/f13/isers-build-thread-1401938/"][B]MY BUILD THREAD LINK[/B] - [I]Updated on THU 23MAY2013[/I][/URL]

[B]Specs[/B]- 97 ZJ 5.2L - 4" Zone Lift - 285/75R16 Cooper STT
[B]Upcoming Projects[/B]- Front Axle Swap. On the look out for HP30.
_______________________________________________

[B][I]"lead me, follow me or get the hell out of my way"[/I][/B]
- gen. george patton
iser is offline   Reply With Quote
Unread 08-06-2012, 08:34 PM   #5
Murdered0utGC
Registered User
2000 WJ 
 
Join Date: Jul 2012
Location: Omaha, Nebraska
Posts: 11
Thanks for the responses guys, Ill get to it tomorrow and let you know how it goes!
Murdered0utGC is offline   Reply With Quote
Unread 08-07-2012, 12:13 AM   #6
plafranx
Registered User
1995 ZJ 
 
Join Date: Mar 2012
Location: Hillsboro, Oregon
Posts: 36
Quote:
Originally Posted by iser View Post
seafoam. i am a believer.
^ Agreed. Since you're seafoaming, might as well put some in the crankcase and change your oil afterwards. I use an aerosol bottle on the throttlebody for ease.

Quote:
Originally Posted by Murdered0utGC View Post
Thanks for the responses guys, Ill get to it tomorrow and let you know how it goes!
FYI You need a T-20 (Torx bit #20) socket to remove your IAC.
Hope it solves your problem so you can move on to the next of hundreds.

__________________
Let's bust a nut
plafranx is offline   Reply With Quote
Unread 08-31-2012, 07:07 PM   #7
Murdered0utGC
Registered User
2000 WJ 
 
Join Date: Jul 2012
Location: Omaha, Nebraska
Posts: 11
Just an update, I used the Aerosol seafoam and it worked like a charm! I am now a seafoam believer, hasn't died on me since! thanks for the help guys!
Murdered0utGC is offline   Reply With Quote
Unread 09-02-2012, 10:44 AM   #8
Darman
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Yellowknife, NWT
Posts: 545
mine idles around there. i clean the IAC and seafoamed. still idles there just fine. if i let off the brakes a little bit itll start to shutter forward. like i can feel every piston firing.
Darman is offline   Reply With Quote
Unread 09-03-2012, 02:58 PM   #9
Myusername1674
Web Wheeler
 
Myusername1674's Avatar
1995 ZJ 
 
Join Date: Dec 2011
Location: Chattanooga, TN
Posts: 2,098
Mine idles really low to, in park at around 500, and stopped in drive around 200-300. I need to do a tune up soon, never cleaned my IAC but have seafoamed through the brake hose line. Maybe I'll seafoam again just everywhere
__________________
95 ZJ, Build in progress
Myusername1674 is offline   Reply With Quote
Reply

Tags
idle , low
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.