JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   Really low idle, not sputtering or dying? (http://www.jeepforum.com/forum/f13/really-low-idle-not-sputtering-dying-1401864/)

Murdered0utGC 08-05-2012 08:01 PM

Really low idle, not sputtering or dying?
 
Hey guys , I have a 96 GC Limited with the 5.2 in it, and when I start it up, it starts perfect, but once I start going, whenever I stop at a stop sign or a light, it idles at like maybe 300-400 rpms? the very first line on the tachometer above zero. It NEVER dies, NEVER sputters, idles just perfect. Is this something I should be worried about?

plafranx 08-06-2012 01:33 AM

Try cleaning your idle air controller (IAC) and throttlebody. Mine Idles perfectly now.

Grand_ZJ 08-06-2012 01:58 AM

^ I agree. Usually a low idle problem is a case of a dirty TB.

iser 08-06-2012 08:17 AM

seafoam. i am a believer.

Murdered0utGC 08-06-2012 08:34 PM

Thanks for the responses guys, Ill get to it tomorrow and let you know how it goes!

plafranx 08-07-2012 12:13 AM

Quote:

Originally Posted by iser (Post 13977664)
seafoam. i am a believer.

^ Agreed. Since you're seafoaming, might as well put some in the crankcase and change your oil afterwards. I use an aerosol bottle on the throttlebody for ease.

Quote:

Originally Posted by Murdered0utGC (Post 13981087)
Thanks for the responses guys, Ill get to it tomorrow and let you know how it goes!

FYI You need a T-20 (Torx bit #20) socket to remove your IAC.
Hope it solves your problem so you can move on to the next of hundreds.

:2thumbsup:

Murdered0utGC 08-31-2012 07:07 PM

Just an update, I used the Aerosol seafoam and it worked like a charm! I am now a seafoam believer, hasn't died on me since! thanks for the help guys!

Darman 09-02-2012 10:44 AM

mine idles around there. i clean the IAC and seafoamed. still idles there just fine. if i let off the brakes a little bit itll start to shutter forward. like i can feel every piston firing.

Myusername1674 09-03-2012 02:58 PM

Mine idles really low to, in park at around 500, and stopped in drive around 200-300. I need to do a tune up soon, never cleaned my IAC but have seafoamed through the brake hose line. Maybe I'll seafoam again just everywhere :thumbsup:


The time now is 10:13 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.