Random hard start and dying 94 4.0 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Random hard start and dying 94 4.0

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRubicon Express Suspensions from CCOR 706-207-4140Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955

Reply
Unread 04-05-2006, 02:21 PM   #1
weaksauce
Registered User
 
Join Date: Feb 2006
Location: Dallas,TX
Posts: 17
Random hard start and dying 94 4.0

I just picked up this 94 GC with a 4.0 in it. Every now and then it will crank and crank and not start. Then when I am driving down the road, it will act like it is shifting really hard like it missed a gear, but the tach sweeps towatrds 0 for just a split second.
I replaced the coil the first time it did it with one from Napa. After I replaced it, it strated right up, but I think it was coincidence.
I also have a problem with fuel leaking at the rear of the truck when the tank is topped off. Could these two be related? The PO said he replaced the fuel pump right before I bought it.
HELP....
Jeff

weaksauce is offline   Reply With Quote
Unread 04-10-2006, 10:39 AM   #2
weaksauce
Registered User
 
Join Date: Feb 2006
Location: Dallas,TX
Posts: 17
no love for my problem?
weaksauce is offline   Reply With Quote
Unread 04-10-2006, 05:52 PM   #3
BradBurdett
Registered User
 
Join Date: Nov 2004
Location: Bay Area
Posts: 214
did you change the spark plugs and wires? that could play a big factor in the start up.

how many miles does it have??

also if it is shifting irratically then check the tranny fluid level, if that is fine then check the linkage to the transmission to and from the computer and also any other mechanically linkage
__________________
1995 ZJ 4X4
command-trac (NP231) with SYE
K&N FIPK intake
RE 6.5in lift with 33X12.5 BFG MT and no Rear Sway bar
4.56 gears--axle swap soon
BradBurdett is offline   Reply With Quote
Unread 04-10-2006, 06:01 PM   #4
dpierson
Registered User
 
Join Date: May 2004
Location: Portland, OR
Posts: 868
I vote for a bad Crank Position Sensor (CPS). This sensor located on the upper driver side of the transmission bell housing tells the engine when to fire the spark plugs. They have a tendancy to go bad and when they do you either get hard starts, no starts, or the engine dying.
__________________
Dan

Traded 8/9/07

[SIZE=1]Black 94 ZJ Laredo 4.0L 42RE/NP231 Command Trac
Sylvania Silverstars, Alpine CD Head Unit, Pioneer 3-Ways in the Doors, Blacked Out Grill, Kolak Exhaust, Clear Corners, Bilstein Shocks, Gas Tank Skid, Rear Hitch, Hitch Wiring, TC Skid, Hellwig RSB, Military FSB, Brembo Front Rotors, OME SS, B&M Supercooler, RE Tie Rod, Limited Power Leather Seats, 30x9.5 Toyo Open Country ATs, Optima Red Top

Next Mods: Upgrade Battery Cables, Sliders, Black Steelies, 3" Lift, Rear Locker, Bumper, HO Alternator, Winch, Driving Lights[/SIZE]
dpierson is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.