Random dying and no start uggh. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Random dying and no start uggh.

Engo LED Flush Mount Lights *PAIR* Flood or Spot 1,600 LumYukon Ultimate 35 axle kit for c/clip axles with Yukon ZipRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 05-07-2007, 08:39 AM   #1
freakydiver
Registered User
 
Join Date: Oct 2003
Location: Golden, CO
Posts: 64
Random dying and no start uggh.

Sorry if this has been discussed prior, didn't get much thru search so hear it goes.

A week ago, packed up my 98zj to go to the airport 3am, started up the truck just fine. I'm heading inside to grab the first kid and I hear the jeep just die. It wouldn't start back up at all. Tried starting over the next few days randomly with no luck then one morning, it starts no problem. It drove fine for a couple of days and then just died while driving. It did restart with some prodding, ran fine for a couple more days and last night it died again.

Anyone ever experience anything like this? I'm *hoping* fuel pump maybe???

Thank you all in advance.

freakydiver is offline   Reply With Quote Quick reply to this message
Unread 05-11-2007, 09:27 AM   #2
John in MA
Registered User
1994 ZJ 
 
Join Date: Jun 2006
Location: MA, USA
Posts: 831
Check engine codes, check fuel pressure and sound, and keep going from there.
John in MA is offline   Reply With Quote Quick reply to this message
Unread 05-11-2007, 10:22 PM   #3
mattwa311
Registered User
 
Join Date: Mar 2007
Location: chicago
Posts: 14
same for me. i took it to the mechanic the first time and he switched one of my relays. Then it died again like 3 days later. Than he said it was some o2 **** and he fixed it, and its been money for about 3 months now, so i think its ok.
mattwa311 is offline   Reply With Quote Quick reply to this message
Unread 05-12-2007, 12:08 AM   #4
lloydjv
Registered User
 
Join Date: Aug 2006
Location: McKinney, TX
Posts: 60
Check your engine codes first. I would guess the Crankshaft position sensor has gone bad.
If not, check all battery and alternator connections for bad contacts.


Could be the fuel pump though. Have it pressure tested.
lloydjv is offline   Reply With Quote Quick reply to this message
Unread 05-12-2007, 01:11 PM   #5
LeroyJMC
Registered User
1994 ZJ 
 
Join Date: Feb 2007
Location: North GA
Posts: 488
Sounds similar to my problem that I had a few months back. In my case there were no trouble codes. The fuel filter and fuel pump was changed and I haven't had a problem since. It's been about 700-800 miles.
__________________
2009 Red Rock JK Unlimited Rubi
2006 Scion xA
1999 WJ Limited Quadradrive V8
1997 Chevrolet Z71
1994 ZJ Laredo 4.0 - Sold
Thanks for the IR Remote Smokinbk.
LeroyJMC is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.