Radio Won't Turn On - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Radio Won't Turn On

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits End of Summer Sale, 20% OFF!

Reply
Unread 09-04-2014, 11:29 PM   #1
KillNThrill24
Registered User
1993 ZJ 
 
Join Date: Dec 2012
Location: Berea, Ohio
Posts: 69
Radio Won't Turn On

Getting more and more things straightened out on this pig. IAC valve on the way for the wonderful low idle. Next on the list is electrical

Radio will not turn on at all. It's an aftermarket, worked fine before it sat for 9 months (December till a few days ago). Now it wont turn on. The power outlet won't work either. I found a burned out 10amp fuse in the passenger fuse panel and replaced it, still no juice.

Prior to this issue the radio would turn cut out and eventually lose all power whenever you pressed the brake pedal. Buddy of mine told me to check for the frayed wires down by the brake pedal and I was shocked to see the massive harness smashed against it. I moved it up and out of the way so if I can get some power to it I'll be curious to see if it works. Also I have no power to my front passenger door whatsoever. No windows, locks, nothin! I have the door panel and speaker pulled out of it at the moment, cannot find any exposed copper in there....

Any insight is greatly appreciated

KillNThrill24 is offline   Reply With Quote
Unread 09-05-2014, 04:36 PM   #2
Alexandru999
Registered User
1997 ZJ 
 
Join Date: Dec 2013
Location: Laval, QC
Posts: 91
did you check the wire for the doors in between the door and body? there is a boot covering them as they go inside your door, pull it out and check for wire damage

as for your radio, many aftermarkets have a fuse (like any fuse in your interior fuse box) right behind where the harness is, check that it might be blown

you may want to disconnect the battery cables, let it sit for a few minutes, plug them back for a "reset" .... mmmm what else

do you have remote start / anti theft / alarm wtv on it? ........ did you fix those broken wires you had at the brake pedal?
Alexandru999 is offline   Reply With Quote
Unread 09-07-2014, 12:12 AM   #3
KillNThrill24
Registered User
1993 ZJ 
 
Join Date: Dec 2012
Location: Berea, Ohio
Posts: 69
Oddly enough I didn't see any wires broken on the harness up against the brake pedal but with as thin as the insulation is on the wires I wouldn't be totally shocked if they had a small wear in them and are arcing that way. Needless to say I completely relocated the harness away from the pedal. I mean the harness was literally FLAT from being pushed up against the pedal arm. I've never seen that before. Fingers crossed that that's my issue, LOL.

Radio ended up being something totally different from anything anyone else will probably ever have to deal with. I had to run a power wire at one point and I forgot to hook it back up to the battery. I had a viper alarm on it, but my parents borrowed my truck key one day last year that had my remote on it and my mom lost the entire set, so I pulled the alarm back out because it was just tons of issues without the remote.

I'm going to be opening up the boot again tomorrow to double check for broken wires tho because the door is one of the main issues I have left. Thanks for the reply!
KillNThrill24 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.