Radio issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Radio issue

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectSavvy Aluminum Gas Tank Skid

Reply
Unread 11-24-2012, 08:11 AM   #1
dusterdude
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: hopewell, va
Posts: 2,044
Radio issue

96 limited with infinity am/fm cassette,radio has started to lose sound.at times it hisses and scratches like a bad antenna connection and at times it just goes quiet,still have power coming in,the clock works and the stations still show up.any ideas?

dusterdude is offline   Reply With Quote
Unread 11-24-2012, 08:29 AM   #2
9859limited
Registered User
1998 ZJ 
 
Join Date: May 2011
Location: Woburn, Ma
Posts: 209
Not to sure but sounds like factory amp is blown to me.
9859limited is offline   Reply With Quote
Unread 11-24-2012, 09:59 AM   #3
Scopez
Registered User
1994 ZJ 
 
Join Date: Oct 2011
Location: Aiken, SC
Posts: 1,711
Check all the connections on the amp and on the head unit.

Unplug the connectors and check the pins. Check the antenna connection both on the head unit and under the hood.

I believe someone cleaned the connections on the antenna from all the gunk and it was a huge improvement. I'll see if I can find that thread again.
__________________
94 ZJ Laredo. 5.2 Crate engine. 6in JKS SA Lift. 33in Destination MTs. ARB Front Bumper.
Scopez is offline   Reply With Quote
Unread 11-25-2012, 12:34 PM   #4
dusterdude
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: hopewell, va
Posts: 2,044
Damn,was hoping i didnt have to pull the hu out
dusterdude is offline   Reply With Quote
Unread 12-19-2012, 03:02 PM   #5
graffix000
Registered User
1994 ZJ 
 
Join Date: Aug 2007
Location: PA
Posts: 54
Did you have any luck with this? i am having the same issues on my 94 zj with the infinity gold setup.
graffix000 is offline   Reply With Quote
Unread 12-19-2012, 05:32 PM   #6
Coastaljag98
Registered User
1995 ZJ 
 
Join Date: Oct 2012
Location: Apalachicola, FL
Posts: 34
This is not the amp. If the amp were blown you'd have no sound all the time period. It's the volume knob on the head unit. you can have the head unit repaired for 100 bucks or get a new used one off ebay for same price. I just bought a used one off ebay and will have my original repaired.
Coastaljag98 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.