radio expert needed - JeepForum.com
 
LinkBack Thread Tools
post #1 of 13 Old 08-08-2013, 06:31 PM Thread Starter
da8
Registered User
 
Join Date: Apr 2013
Location: Monessen
Posts: 52
radio expert needed

I bought a 98 zj limited. Only the front right door speaker worked. I thought it might be the radio so I changed that out. it wasn't. I thought it might be the speakers so I took the rear door speaker out and put a new one in. Nothing, no sound. Anyone know why this would be happening. Only sound in the right front door speaker. The tweeters in the dash do not work either.
Thanks

da8 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 08-08-2013, 06:49 PM
JeepNicholson
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Burbank
Posts: 753
It's a long shot, but make sure the pins in the radio harness plugs aren't pulling out
JeepNicholson is offline  
post #3 of 13 Old 08-08-2013, 06:57 PM
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint
Posts: 2,154
It's bad wires.

3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline  
post #4 of 13 Old 08-08-2013, 06:57 PM
jtackerman28
Registered User
1997 ZJ 
 
Join Date: Nov 2011
Location: Flint
Posts: 2,154
You'll have to run all new wires.

3.5 re lift, double sheer front tb, 31" wrangler duratecs
jtackerman28 is offline  
post #5 of 13 Old 08-08-2013, 07:16 PM
BlastMasta
Registered User
1996 ZJ 
 
Join Date: Jul 2012
Location: Philadelphia
Posts: 143
Does it have a factory amp?
BlastMasta is offline  
post #6 of 13 Old 08-08-2013, 07:44 PM Thread Starter
da8
Registered User
 
Join Date: Apr 2013
Location: Monessen
Posts: 52
not sure, how do i tell?
da8 is offline  
post #7 of 13 Old 08-08-2013, 07:53 PM
JeepNicholson
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Burbank
Posts: 753
Quote:
Originally Posted by da8 View Post
not sure, how do i tell?
It'll be under the back seat and looks like this

http://cdn.stripersonline.com/1/13/1...tach437125.jpg



ZJ FSM
https://drive.google.com/folderview?...Fk&usp=sharing
JeepNicholson is offline  
post #8 of 13 Old 08-08-2013, 08:00 PM Thread Starter
da8
Registered User
 
Join Date: Apr 2013
Location: Monessen
Posts: 52
yes, it has it. what now?
da8 is offline  
post #9 of 13 Old 08-08-2013, 09:17 PM
jabba974
Registered User
1996 ZJ 
 
Join Date: Mar 2013
Location: Ionia
Posts: 246
Good possibility its the amp...try replacing it or eliminating it from the system..
jabba974 is offline  
post #10 of 13 Old 08-08-2013, 10:10 PM
wickedkingszj
Registered User
1998 ZJ 
 
Join Date: Dec 2011
Posts: 12
Did you try to replace the factory head unit with an aftermarket or do you plan on doing so?
wickedkingszj is offline  
post #11 of 13 Old 08-08-2013, 11:31 PM
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 5,006
It could be the amplifier.. You can get them from a Junkyard limited (or Laredo if it had it) for like $10.. I found the original amp in a 5.9 for my 5.9 which previous owner took out.. its 180watts.. I think yours is something like 90 or whatever got mine for 10$

However it could be bad wiring... My 98 Laredo has no amp, just the head unit and the front speakers don't work very good anymore like no sound coming from them... It just be bad speakers I know is bad so I unplugged it

2013 6.2 V8 Camaro SS 30k
98 5.9 V8 ZJ 180k
98 4.0 I6 ZJ 240k
90 5.9 SJ Grand Wagoneer 110k
Candymancan is offline  
post #12 of 13 Old 08-10-2013, 09:21 PM Thread Starter
da8
Registered User
 
Join Date: Apr 2013
Location: Monessen
Posts: 52
Thanks Everyone, it was the amp. Works fine now
da8 is offline  
post #13 of 13 Old 10-15-2013, 07:08 PM
Rosslato
Registered User
1994 ZJ 
 
Join Date: Sep 2013
Location: westland
Posts: 31
Quote:
Originally Posted by da8 View Post
Thanks Everyone, it was the amp. Works fine now
I'm having a similar problem, did you replace the amp or find the problem?
Rosslato is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome